Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

SumatraPDF stopped opening PS, EPS and PRN files (PCL etc.)

Not so many people need to open PS and EPS documents via SumatraPDF and Ghostscript. This may be the reason why nobody noticed that, since October 2020 release of Ghostscript 9.53.0, SumatraPDF stopped to work with PS and EPS formats. This concerns Sumatra 3.1.2 x64 portable and pre-releases of 3.3 x64 portable, I tested only them. Sumatra 3.1.2 and 3.3 work fine with the older Ghostscript 9.52 (and I returned to this version of GS). What can be a reason why Sumatra likes GS 9.52 but dislikes 9.53.0 – 9.53.3 and 9.54.0? I believe that SumatraPDF cannot call the new versions of GS with the new four-digit version numbers but can call GS with a three-digit version number. It is said on the GS site that a similar problem appeared for GSview: " (9.53.0) As of 9.53.0, we have (re-)introduced the patch level to the version number, this helps facilitate a revised policy on handling security related issues. **Note for GSView Users:**The patch level addition breaks GSView 5 (it is hardcoded to check for versions 704-999. It is possible, but not guaranteed that a GSView update might be forthcoming to resolve this."

The “error” message problem should only appear with version 9.54 and later.

SumatraPDF has for over a decade used the same call to GS as many other apps including GSView but unlike GSView did not depend on the 9.99 subversion limit, thus was/is working for me up to version 9.53.3
Ignore the PDF references that is because I use SumatraPDF to save as faster PDF the important part is that I used 9.53.3 to open the PRN and thus it shows it works

The “issue” is known and will need to be fixed, see Ghostscript not working -- "Error loading ..." on .ps files

thus you only have 2 options for now.

  1. uninstall 9.54 (its pointer may still be stuck in the registry)
  2. Hot-patch SumatraPDF to NOT use the legacy part of GS call which raises the GS error. This is not easy since then you would either need to compile your own copy OR flout the AGPL license by modifying an existing binary. It is an Irony that the need arises due to non interaction between 2 Artifex libraries.
1 Like

Sorry, I agree that 9.53.x is not affected, I should better clean up my system when I removed 9.54.0. Thank you very much.

1 Like

Latest pre-release version (https://www.sumatrapdfreader.org/prerelease) should now work with Ghostscript 9.54+.