Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Ghostscript not working -- "Error loading ..." on .ps files

Problem summary: I cannot get Sumatra to display .ps or .eps files. It says "Error loading " on the top message bar. I’ve actually had this same issue on two different Win 10 PCs just in the last day (though I hadn’t tried for a while now).

Configuration: I’m using the very latest version of Windows 10 64-bit as of 4/17/21–all updates installed. In fact, I just had to re-install Windows 10 last night due to update errors. I’ve installed Sumatra PDF 3.2 64-bit and I’ve installed multiple different ghostscript versions including the AGPL v9.54.0 64-bit. All installs are to default locations and I even put the ghostscript “bin” folder in my path. The ghostscript “ps2pdf” batch file seems to work fine to convert .ps to .pdf.

Anybody know what is going on? Did the latest Win 10 update break the connection between Sumatra and Ghostscript for reading postcript files? I am stumped. Any debugging tips?

Hi Willus
9.54 is breaking 10 year old code, Long discussion here
see AGPL GhostScript 9.54.0 not recognised then changes API · Issue #1923 · sumatrapdfreader/sumatrapdf · GitHub

TL;DR any SumatraPDF.exe either needs a patch to work with 9.54 or continue to use 9.53.3 until SumatraPDF pre-release catches up with GhostScript

Okay thank you. I installed 9.27 but had not uninstalled 9.54. It hadn’t occurred to me that 9.54 might be broken. It worked with a couple of other apps I have that use Ghostscript. Anyway, it works now. Thanks again.

SumatraPDF looks for the newest so if there is 9.53.3 64 bit and 9.54.0 32bit it will error

see the github entry as to how to HEX patch your preferred SumatraPDF.exe OR revert any GS to not include an installed 9.54 (sorry)

I’ll just wait for the next Sumatra release. I have no particular need for GS 9.54. Love Sumatra, BTW. My favorite PDF viewer.

I have K2PDF setting in my environment are those your doing :smile: ( need to ensure portable use is not sticky) and have you tested GS 9.54 docxwriter ? I was wondering about addin a docx export to SumatraPDF open with
[Later edit]
9.54 docxwriter is on first looks basic, it re-flows the formatted text but they are not bound by the objects area nor will it include images in this 9.54 release.

Have not tested the docx writer. k2pdf sounds like me. What do you mean by “portable use not sticky”?

I expect my preferred single exe apps to keep settings in their own folder, as do most portable applications, I did not see a way to specify such behaviour in k2PDFopt, is there a setting I was too lazy to read? I dont remember adding 5-6 entries in user environment
PS I can not run the 64bit on this basic laptop but note you are aware that is often an issue and both 32bit versions work but screen defender does not like the 32bit alternative version

I’d be interested in discussing further but it’s not topical to this thread. Can you send me an e-mail on my web site?

1 Like