White stripes when printing to Xerox printers


#1

I’ve been using SumatraPDF to print PDF documents, but now having issues when printing to Xerox WorkCentre network printers, where the print output is interrupted with horizontal white stripes.
Attached I’ve uploaded a scanned output printed with Sumatra that illustrates the issue.
The exact same PDFs printed from the same computer to the same printer using another PDF reader is printed with no issues.

Sample:

Any hint on what may be causing this issue?

Thanks,
Alberto Silva


#2

Small detail I forgot to refer, if I print from SumatraPDF to “Microsoft Print to PDF” or “Microsoft XPS Document Writer”, the output does not have those white stripes. Unfortunately I only have Xerox printers available in this network to test with.


#3

It appears to be a known problem with Xerox ( and a few other) print drivers and their image stream handling see
https://github.com/sumatrapdfreader/sumatrapdf/issues/417 #685 #919 #975 #992 #1058 #1081 if you can track down a setting that reliably clears this issue many business users would be happy. Suggestions that have helped some of the above are the stream format such as emf/raw etc enhancement settings such as PSlevel/optimisation.


#4

Thanks, interesting that another business AIO Xerox (C7022, IIRC) I tested afterwards in the same network is printing fine. As soon as I get back there I’ll see if I can do some more testing in those “WorkCentre” models based on the suggestions from tose links.