What is this feature and how do I turn it off?


#1

I use Sumatra on a Tablet pc primarily and there is this really annoying feature I want to disable, but I have no real idea how to describe it.

I also have no idea how to use this forum so I hope those pictures worked.
The problem is when I go to close the right most tab, as in physically touch the ‘x’ with my figure, rather than closing these arrows come up. The only way to close the right most tab then is to drag it too the left, making it not the right most tab.
Any information on what this feature is called and how to disable it would greatly appreciated.


#2

Which version of Sumatra do you have installed? Have you by any chance installed it from the Windows app store? If so then that is an illegal unsupported version.


#3

I also use it on a tablet and I haven’t noticed that
you could try the latest prerelese build as I always use those maybe it’s something tat was fixed
https://www.sumatrapdfreader.org/prerelease
and I’d avoid the win store version as that is done by a 3rd party not sure how up to date the code is and how clean is it


#4

It looks similar to issues created by using non recommended screen DPI settings, out of interest is your screen resolution in windows not 100% and where in your system is that setting shown


#5

I have V 3.1.2. I did uninstall and reinstall, but the issue persists.
I installed the prerelease V 3.2.11105, and the issue persists in that version as well.
I am running the native resolution on my machine, which for reference is a Surface Pro 4.
I have also noticed this only happens when the tabs consume the entire width of the window.


#6

So I performed an experiment: I got the problem to arise, then changed the tab width from 300 to 200 and the problem went away, so it is defiantly caused by the tabs consuming the width of the window. I would guess these arrows are supposed to scroll the tabs left and right if you have too many to be displayed at once. But, something I may have failed to mention, the arrows don’t do anything at all.
It’s seems to be that this is something I could disable in the code, similar to changing the tab width, if only I knew what to look for.


#7

I’m not sure why it’s not working for you but for me when I open a lot of files the tab width reduces so all tabs are shown here’s a screenshot from my 8’ tablet running prerelease 3.2.11126


in the advanced settings file the only tab related settings I have are
PrereleaseSettings [
TabWidth = 300
]
and
UseTabs = true
I haven’t changed any tab options
try with a new settings file if the issue persists open an issue report over at sumatra’s git page