Vulnerabilities in NVD

The National Vulnerability Database lists 5 HIGH vulnerabilities over a rather large period of time. The change history does not directly reference any of these vulnerabilities as having been fixed.
Can you let us know if these have been fixed?

Thanks

Which of the CVEs mention that they affect Sumatra 3.1.2 and later?

NVDs don’t always site a range of versions that are affected, and even then there is some doubt.
In this case there is only one of them where it is unclear which versions of Sumatra are affected.
CVE-2012-6535.

But I guess what I am really asking for is to include the CVE number in the change log when it is fixed.
BTW this all came about as I was recommending Sumatra on the HISAC forum as a much safer PDF viewer than any of the other offerings (such as Adobe or Foxit) for hospitals to utilize.