Forum moved here!

Home / The words almost merge together. How to increase spaces between words?


Sumatra PDF shows PDF and DJVU books very well.
However, when I try to read EPUB files, they are almost unintelligble. This is because the intervals between words are almost absent. In some lines the spaces between words are visible, in others all words in a line are merged into a giant word.
How to increase the minimal width of the interval between words?
The display of my laptop is 3840 × 2160, the diagonal is 17".
The scaling in Windows is 350%.
(If I change the display scaling in Windows to 100%, the spacing between words become approximately the same as the letters width, but the letters on my laptop become too tiny).
The only change in my SumatraPDF options is “Single Page”. All other options are default.


That sounds unusual but could be down to the high screen resolution settings in windows.

I can only test at most running up to 200 % and the words there are clearly spaced.
For eBooks SumatraPDF uses one single font at a set height and it is possible the character for the space between words is somehow affected in your system more than in others.
The only adjustment is to try a different font or alter windows compatibility settings.

In settings advanced options you could try

EbookUI [
	FontName = Arial
	FontSize = 20

and on a shortcut to sumatraPDF try changing some dpi values


Thank you very much for helping ideas!

I think SumatraPDF gives a constant number of dots for a space.
It also aligns text both left and right, adding space between words. If there are only few words in a line, then spaces between each pair of words extend enough.

Probably, your display is less than 3840 dots in width. Maybe also you SumatraPDF shows a text in two columns. So running at 200% gives few words per line.

I tried your idea with a font and changing DPI values on a shortcut. Using a large font doesn’t help. Fiddling with DPI values on a shortcut partially helps. However, these options are for old applications, which are not DPI-aware. I switched from STDU viewer to Sumatra PDF viewer exactly because STDU is DPI-unaware.

I hope that the author of Sumatra PDF will fix this issue in his excellent viewer.