Switch between save & open in firefox browser


#1

Hello.
How can I switch beetwin Record or Open a PDF file. Now, it’set on Record, and I don’t need always to keep the document.
Thank you for your replies.
Have a nice day.
Toto


#2

@tutu
I am not sure what you mean by “record”
there are two boxes in Settings > Options (below change language)

View > Remember these settings for each document
Advanced > Remember opened files

have you tested clearing the second one ?


#3

Good Morning.
Tha,k you for your answer.
When I select Settings, Options, I open a window :slight_smile: Dummy,
in which I can only change the size of the document.
Maybe should I download a new or different version …
I apologize for my english, i write from France.
Have a nice day.
Tutu


#4

To complete my answer, when I open a PDF file on internet, I must first save it to be able to open it after.
I would prefer to open it, by default, instead of save it.
I hope I’ve been clear enough.
Thank you for your help.


#5

@tutu
I see you have in your picture cleared

[ ] “Se rappeler les fichiers ouverts”

OK , however you appear to be referring to usage whilst downloading from a browser
where the options are SAVE (record ?) or OPEN
That function is browser dependant. In the past “installed” version of SumatraPDF would allow you to instantly OPEN a temporary downloaded file from the browsers cache and depending on the browser that could be set to delete files on closure.
Many portable users would adjust firefox or iexplorer to use SumatraPDF as the PDF handler but you still need the browser to do the clean-up afterwards, so I usually accept using SAVE by default and manually delete those files I don’t want.

Which browser are you using ?


#6

My browser is Firefox


#7

@tutu
You need to consider changing the way firefox opens a PDF make a note of your current settings
and try the following (note PDF FILES are ALWAYS downloaded even if to a temporary location
in Firefox (or IExplorer) you need to ensure the option for delete temporary files is activated




#8

As pointed out above, this isn’t a Sumatra issue. Anyway, to do what you want, in Firefox go to Options > General and in the Applications list make sure the Action for all PDF-related Content Types is set to “Always ask” or “Use SumatraPDF” as per your preference:


#9

Thank you for your advices and your help.
It works and I don’t have no more to save the file before opening it.
Have a good night.:clap::clap:

[moderator comment] Bonne nuit