Support for Smooth Scrolling?


#1

While scrolling up or down it seems kind of jittery/jerky in Sumatra in comparison to opening a PDF via browser. I believe this has something to do with smooth scrolling? I’d like to request that some form of smooth scrolling be added to make it a bit easier on the eyes.

Great app by the way, switched from adobe reader ages ago and I love how light it is at the moment.


Scrolling on HiDPI settings
#2

I reported the same thing a few weeks ago. I had smooth scrolling in Windows 10 prior to the Anniversary Update but it didn’t work any more after the update. I had to reinstall Windows 10 again because of some other issue and it didn’t fix it either. I have the last version, v.3.1.2 64bit.
P.S.: I am talking about the touch pad. It was a fluent motion as like moving a paper with my fingers and now it’s jumpy.


#3

@ema93a: Does your laptop have the latest touchpad driver installed? (See if the touchpad manufacturer’s site has a later version than is available via Windows Update.) Also, does your laptop have a Precision Touchpad? Have you tried the latest pre-release version of Sumatra?

You can also check whether having everything enabled under Performance Options helps in any way:


#4

Thanks for the tips, I have tried all of them but unfortunately it did not work. Does this affect all laptops with Precision touchpads or just mine? As about your tips:

  • I have the latest drivers installed according to Windows Update but just in case I installed my manufacturer’s latest version and it didn’t work.
  • Yes, my laptop has Precision Touchpad.
  • Yes, I just uninstalled the latest stable version and tried the pre-release one but no luck with that either.
  • Yes, I had many settings disabled but enabling all of them didn’t help. I also tried enabling the “enable animations” under Ease of use in W10’s settings but didn’t help either.

I think I am going to contact my manufacturer’s support center and ask them about what could have been wrong with the driver after Microsoft’s update.
Nevertheless I’ll keep using SumatraPDF because I love it :slight_smile:


#5

This seems to affect all laptops with precision touchpads. Before the Creators Update, Windows detected applications that were not using the new APIs (WM_TOUCH/WM_GESTURE) and emulated smooth scrolling by directly manipulating the scroll position. For some reason they’ve now stopped doing it, so “legacy” apps have reverted to classic scrolling via WM_SCROLL/WM_MOUSEWHELL. All this was mentioned in a few discussions, including this post on reddit and although I haven’t tested it myself, it does make sense.

The only solution would be SumatraPDF becoming touch-aware. I don’t know how hard that would be, since I’ve never used those APIs. Hopefully it would be pretty trivial. If the devs have no time for this, I’ll probably give it a try myself eventually.

As for contacting support… in the post I linked above, someone tried contacting Microsoft about their XPS 13 (which I also happen to own) and their response was to rollback to the Anniversary Update, which I see as a bit too drastic. I’d rather pester @kjk about “modernizing” SumatraPDF instead. :stuck_out_tongue:


#6

Does anyone other than the developers have an idea about how to fix it? I don’t have any experience on programming apps but if someone does, it could be of a great help.


#7

UPDATE: I just got the Fall Creators Update and it did add the smooth scrolling back in apps such as the Windows Explorer but unfortunately it didn’t revert the changes it did to SumatraPDF when we got the Anniversary Update. I also posted a description in Windows’ Feedback app a long time ago but I guess they ignored it. If anyone wants to help, they can upvote it here or searching for “No smooth scrolling after Creators Update” in the Feedback app.
Thanks.