Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

SumatraPDF 3.1.2 gets stuck in rendering state

Hello,
I am using SumatraPDF v. 3.1.2 64-bit on Windows 10, and I am encountering the following unpleasant problem: I frequently use it together with MikTeX pdflatex to view LaTeX documents. Recently, I generated a pdf document with pdfLaTeX (a document which until then worked OK); but SumatraPDF would not go beyond the rendering stage (i.e., nothing was visible). When I tried viewing with other pdf viewers (e.g., TeXWorks, Firefox, Microsoft Edge) there was no problem (i.e., it worked). Can someone suggest how I can figure out what is wrong and how to fix it.
Regards,
bostjanv

Hi
There are a few reports of LaTeX issues but without Minimal Working Examples of the PDF output we cant guess at an individuals problems, The best way to get it reveiwed is check you have a consistent problem file, test that it misbehaves with all hardware settings at normal e.g. SumatraPDF on main monitor with windows hardware scaling at 100% then if not a problem detect what makes a difference
Ideally test on another device however if still a problem getting it to display then open a Ticket with upload to

Alternatively provide a link to any clean easy file transfer site (note gett does not work for me)

There’ve also been lots of MuPDF-related as well as other improvements since 3.1.2, so I suggest checking with 3.2 and the latest daily release too before opening an issue. You can use the portable versions in case you don’t want to tinker with your installed version right now.

1 Like

Hello,
Thanks for the replies. Actually, after encountering my problem I checked whether I had the latest version (Help–>Check for updates), and I received the reply that 3.1.2 was the latest version. However, after reading the comments in the replies to my post it turned out that there is a newer version (3.2). So I installed it, and, lo and behold, my problem was gone. Therefore, sorry for the false alarm and best regards.
bostjanv

3.1.2 does still have some benefits for LaTeX users when searching text in a compiled UTF-8 PFD (forward search should be ok i.e. not affected) and is still the most stable so “update” is on lock-down for the present.

The best way to combine version 3.2 and 3.1.2 is to keep a portable copy in a known folder and add to advanced settings

ExternalViewers [
	[
    		CommandLine = "C:\known folder for 3.1.2\SumatraPDF.exe" "%1" -page %p
    		Name = &Version 3.1.2
    		Filter = *.*
    ]
]

Then if you need to open current page in 3.1.2 press ALT + F + V

Thanks for this last information. Will take your advice.
bostanv