Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Sumatra keeps its handle on opened files even when closing the files

Hello,

For example, if I open 5 PDF files, then I close one, that file is still locked in memory. If I try to move or delete that file, I can’t, because that PDF is still locked by Sumatra.

Hope this bug gets fixed.

Thank you,
Temp Man

You should report new issues to

However you will need to provide much more info about version of SumatraPDF, OS, File sizes etc
as I see no bug :frowning:
Using current version 3.1.2
.I can open 5 x 20mb pdf files and get a warning from Windows 7 that they cannot be modified / deleted since they are open in SumatraPDF but when closed any one of them can then be renamed moved deleted etc

Hello,

Thank you for your response. This bug appears to be fixed in the latest version.
I used to experience it in version 3.1.1, but it is fixed in 3.1.2!

Thank you,
Temp Man

Sumatra kept the folder handle open as well even if the file in it was no longer open in the app, but that was fixed in a pre-release version after 3.1.2:

Still the same. Win 10 x64 1909 build 18363.836 . App version 3.1.2 x64.

Not clear which behaviour is

still the same

It was fixed

Should be fixed in latest pre-release 3.2.10688 or later

In 3.1.2 I can delete the PDF I am reading if it is under 10 MB
or in 3.2 I can delete the PDF I am reading if its under 32 MB
those are the FILE unlock limits per version, most other apps like Acrobat lock the file at 0 MB

For the folder locking issue you need to use version 3.2.xxxxx or later

This means, I cannot move files (approx 2-5 Mb) even if tab closed (other tabs with another files are active) until restarting Sumatra.

Oh, Sumatra 3.1.2 notified (manually check) that there is not new versions, but there is a 3.2 :smile:

There is a temporary “hold” on updating all users to 3.2 see https://www.sumatrapdfreader.org/docs/Version-3.2.1.html
but in your case 3.2 should help or try one of the 3.3 versions prerelease

thank you for these tips! :blush: