Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Select Multiple text by double-clicking or drag

Hello, I’ve just installed your software and I can’t seem to be able to highlight a whole line of text by double-clicking on it. If I double-click on the text I’m only able to select that word.

I have tried:

  1. Checking with different .pdf files from various sources.
  2. Read through the advanced settings page.

But, I can seem to find a setting for this.

Thank you for your time.

That’s correct double clicking will stop at the first “space” or non alpha character in each direction thus only a word (or part), otherwise it would not know if to stop at comma, sentence, paragraph, page or document. Some browser applications will only go forward to end of line or select the whole multi paragraph entry, Editors like WordPad often select the whole line.
If you want to select the phrase, line, paragraph etc. in SumatraPDF you need to hold down the left key from the start to the end of your choice. you can use the control key with left mouse to select any rectangular graphic area.

It is very common to allow the same action with double click and drag as works with click and drag, but it selects whole words. I continually find myself trying to do this with PDF documents only to find I’ve only selected a single word and the drag does nothing.

Why not work like the majority of programs and support double click and drag?

1 Like

It is very common to allow the same action with double click and drag as works with click and drag, but it selects whole words. I continually find myself trying to do this with PDF documents only to find I’ve only selected a single word and the drag does nothing.

Why not work like the majority of programs and support double click and drag? It would make using Sumatra much more like the rest of the world and not make the user think about Sumatra differently.

I will say I am very happy with Sumatra. It’s a great program and I’m glad it was developed. It just has a very few nits that I don’t care for.

Link to ancient topic #1, which seems to indicate that this bug was introduced more than half a decade (!) ago (see the last comment): touch commands in fullscreen (archive.org)

Link to ancient topic #2: Text Selection via Touch (archive.org)

Finally, a link to a comparatively ‘recent’ 4+ year old issue on GitHub:

Unfortunately there are a few conflicting issues here

Double click has since the days of TeX Enhancement equalled triggering reverse/inverse search (and is desirable for that function, albeit by a significant minority of users)

Touch screen selection was never developed beyond some experimental phases.

Multi word text selection has AFAIK always been possible when using the mouse by single click and drag, in the same way as variable image area selection is triggered by using control with single click and drag

Yes, the OP knows that (as I guess do we all :slight_smile:), but as he says there’s a difference between single-click+drag and double-click+drag, and sometimes the latter is useful.

I don’t know what to think. Every editor like tool I use and every browser, etc. all respond to a double click and drag by selecting multiple words. This is so much easier than trying to find that 1 pixel wide spot between the letter and a period or whatever else is next to it that I don’t even give it a second thought, I go for the word selection and drag to select phrases.

I guess I’m not geek enough to appreciate concepts that I can’t even really read… from the Github discussion…

Double click PDF in
Acrobat=word only (same drag as SumatraPDF)
Foxit=word only
SumatraPDF=word only
Okular=word only (same drag as SumatraPDF)
Thus no issue since SumatraPDF behaves similar to its peer applications

The two fofou links don’t even work.

I guess I think like a user and not a developer.

Ok, I give up. Either use Sumatra as is or don’t. Don’t bother pointing out ways it can be improved.

[The 2 links as noted by SumatraPeter were archived by the Wayback Machine and have been added later above by GitHubRulesOK: ]

In any case you can clearly see the comment I was referring to:

It seems clear that the code change made to fix the touch issue resulted in this unfortunate loss of functionality.

Let me make it clear that till date you have not received a single response from the developer, so you can’t come to the conclusion that your request has been rejected.

FWIW I think your request has merit and ought to be fixed if possible, especially given that it’s a useful feature and apparently did work once upon a time. Hopefully the developer @kjk can look into it when he has some free time.

Also, all suggestions for improvement are appreciated, although like the rest of us non-coders you’ll just have to give them and then wait (sometimes for years) till they are implemented, if at all. There’s only a single developer working gratis on his FOSS app in his free time, so… it is what it is. :man_shrugging:

AFAIK double click with a pdfsync or synctex file present since the early days (after adding DDE) selected the current line number (or co-ordinates) and runs the -inverse-search command.
“Enter the command-line to invoke when you double-click on the PDF document:”
Without synctex it always selected the current word (exactly the same .pdf behaviour as up to at least Acrobat 9)

The time quoted above would have probably been version 2.0 to 2.5.2 and the behaviour was exactly the same in both those versions then as now.

It is format specific

There IS a difference using ChmUI since that respects HTML selection methods so in a .chm using Chm engine double click and drag selects start to finish.

In a CBX double click selects the whole page in DjVu file it will select the whole line or image only and in epubUI nothing happens NO selection !

According to boon’s comment it seems something changed “in the latest prerelease” back in early 2014. Perhaps in zeniko’s prerelease versions it behaved differently? Not sure, and don’t have the time or inclination to track it down to check. In any case it’s up to kjk if he wants to change this or close the issue once and for all.

When you double click on a word and select it, you can no longer select more words by holding the click and dragging the mouse. You can only select multiple words if you hold click and drag on the text.

This makes it difficult to select multiple words, because that way you select letter by letter, so you have to point the mouse at the beggining of the first letter, which is difficult.

Please! Could you make it possible to select text by double clicking? Double click on a word, hold click and move the mouse to select the phrase you want. Just like happens in internet browsers, Office word, etc.

Kind regards! I love Sumatra PDF.

Long time request see https://github.com/sumatrapdfreader/sumatrapdf/issues/217

Where you may note this was the natural behaviour for a PDF reader long before browsers used a different technique. Double click has two functions one of which to select a word for inverse searching is not so obvious to the majority of users.

SumatraPDF behaviour is identical to Adobe Acrobat, Foxit Reader and Okular
The four main PDF viewer applications as used by dozens of LaTeX compilers.

Its not easy to please everyone, so some want from word to end of the line forwards, and some may want it to be whole paragraph, whilst that all depends on what the underlying language and text spacing allow.

For multiple lines or selecting a paragraph SumatraPDF has marquee selection using CTRL and left mouse. An extra feature not found in those others.

The code to just select one word was not easy and takes a few lines, see the number of issues about multiple word cut and paste “not working” because the underlying character definition is not standard
To do every desired permutation involves considerable, if this / then that deliberations.

I tried in the thread above a means to modify click behaviour which works 50% e.g. click word and drag to right is the easier one, but click and drag to left is not so easy. see https://github.com/sumatrapdfreader/sumatrapdf/issues/217#issuecomment-596605107.

Hi there. I would like the ability to select text with double click and then when I hold the click and move, it increases the selected text by word boundary intervals. Thanks in advance!