Scrolling on HiDPI settings


#1

After updating my dell xps 13 QHD to the windows fall creators update, the scrolling has taking a drastic hit, becoming jerky and whatnot. In fact, this jerky scrolling behavior extends to all apps on my computer that aren’t UWP- themed, like Eclipse IDE and MATLAB.

To see what was causing the issue, I downloaded Adobe Reader DC. I was able to get the same “Smooth scrolling” setting by fiddling with the “Resolution” and setting it to 240 pixels per inch.

My guess is that windows is forcing applications to use their own scrolling settings by default, without consulting the computer’s dpi. This becomes a problem for high DPI screens, since the screen’s scaling is usually set to more than 100%.

Is it possible to adjust DPI/Resolution in Sumatrapdf? If not, will it be implemented?


#2

Scrolling using a scrollbar, touchpad, keyboard?

“Resolution” setting: is it windows setting or Adobe setting?

I’ve opened https://github.com/sumatrapdfreader/sumatrapdf/issues/962 for this issue.

I googled for this issue but didn’t find anything that seemed related.


#3

scrolling using a touchpad, with windows precision drivers. It’s an adobe setting, so the problem has not been fixed in my other applications. The issue I’m having is well described in this post: https://superuser.com/questions/1201986/touchpad-smooth-scrolling-obliterated-in-windows-10-creators-update/1219227

There’s not much else on the internet, not sure why, but I can confirm that it isn’t just a fluke. I’ve tried reinstalling updating windows and playing with touchpad drivers, but no fix.


#4

This is a known issue (for example see the very first line of this recent post). It was reported last year so you might want to look at the original thread for additional useful info.:


#5

Huh. So everyone is experiencing this problem, but not enough people are making a fuss about it on the internet. Have we considered very fine “pixel scrolling?” Apps like sumatrapdf don’t scroll well, but Chrome browser does, and I’m pretty sure that Chrome isn’t using the new touchbased APIs.