Forum moved here!

Home / Problems with the ‘user’ vs. ‘admin’ installation of Sumatra PDF 3.2+


Why did it install to user/appdata/local ?
Why is it asking me if it is okay to open the file, every time I run the executable that is in appdata/local - I shouldn’t have to click on “don’t ask for this file” … because it should not be asking me that in the first place.
Why doesn’t it install in Program Files?
The installation location and the fact that it is asking me each time do I want to open the file makes me wonder if it is even safe to use the program.
Is the installer broken?


Without knowing how your system is set for individual users the best I can suggest is to read Unable to run as standard user #1502 and

A single user install should work by default for one user only.

However, if you have multiple accounts (e.g. basic and admin) with resulting issues over running rights then its best to install a single copy into Program Files (each user account should then have its own settings files without UAC conflics)


I have the only account on the PC. I own the PC. I do not have any user accounts. When I installed your software it did not install to Program Files like a normal program would.

What system information do you need me to show you? If the program is supposed to install to Program Files, it didn’t, and that’s a problem with the software not a problem with my setup.So back to my original question. Problem with INSTALL. Not “user” install.

Why did it install to user/appdata/local?
Why didn’t install to Program Files?


As shown in the above linked discussions. both I as a user and the other user moderator feel this could be handled differently.

If your installation to the local application area causes your installation an individual user rights problems,
Then it is best to uninstall and re-install to normal Program Files area using the installer options button.


Okay, so now I have it installed into Program Files. It still pops up “Security Warning” dialog “Do you want to run this file?” I have the option to take the check mark out of “Always ask before opening this file” - but why should I have to do this?

Is this a normal thing too? No other program i have ever installed to anywhere pops that up. It pops up when I run an installer, as it should, but why is it popping up just because I want to run the program to read a PDF?



Unfortunately Nanny mcSoft is trying its damnedest to protect you from software that is not high on their own list of approved applications, rest assured if you downloaded from this site download page (and not the windows store pirate copy!) then it should be safe to “always run”


That is where I downloaded it from.


This was a common problem introduced by Windows after XP. It is due to combined settings in the system and browser. See

After downloading the file, the browser – both IE and Chrome – adds an “alternate stream” to it, named Zone.Identifier , which says that the file came from the “Internet” zone. When you double-click a file in Windows Explorer, it checks if such a stream is present, and asks for confirmation if necessary. This is not restricted to executables – any file tagged this way will require confirmation.

Oddly wherever Firefox saves my SumatraPDF downloads does not raise the warning but here I downloaded Java Runtime Executable from the reputable Oracle site nine days ago (I may have used Internet Explorer?) and I will need to tick the box to be able to run it without the warning:



I use Windows 10 without admin rights (basic security option :slight_smile: ). When I install the last Sumatra version (3.2), I enter the admin password and the installation seems to work perfectly. But… I cannot open Sumatra… If I switch to the admin account, Sumatra is working perfectly.

I download the previous version (3.1.2) and… everything is perfectly working for all the users.

Thank you for all the work !



Previously reported multiple times but unfortunately the associated issues have been closed without a fix:


You’re right. And there is an answer in the “unable to run…” topic. It is necessary to change the path of the install to C:\Programs Files\SumatraPDF. Not very hard, but just impossible to imagine…

Thank you !


Using Windows 10Pro 20H2, I can install it in the Administrator account, but when I switch to a User account, it cannot access the the admin s %appdata% local folder. The shortcuts are installed on the start menu but denies access.


The default install is for every user to install their own exe . registered dlls and crashreport/debug files alongside their own local settings file.

Admin users should consider multiple users requirements and install into Program Files


Thanks. I will try, but installing for each standard user also requires Admin privileges.


If you install once as admin to program files, each user should not need an install just add the shortcut to public desktop and the app should build each user local settings
I am trying to test on clean 20H right now but expect it to be same as before


I installed at common C:\Program Files as Admin once in 20H2 !OH
Placed a shortcut to C:\Program Files\SumatraPDF\SumatraPDF.exe on the Public Desktop
Added a Basic user
selected a PDF
Basic user was asked if PDF its to be opened with Edge or SumatraPDF
Chose SumatraPDF it opened, No dramas.
No need to install for that user
It generated their personal setting’s in their local appdata NO UAC, No Problem


Much thanks for all your efforts. I know how time consuming it is to test.

Placed a shortcut to C:\Program Files\SumatraPDF\SumatraPDF.exe on the Public Desktop

Was the step missed.

Now all is OK. Thanks again.