Problem with Restrict Options


#1

I use portable version of Sumatra with sumatrapdfrestrict.ini file in the same folder as .exe

The restrictions works fine on one machine (Win10) but when I copy the entire folder to another machine (win7) the restrictions only works only when open SumatraPDF.exe but wen I open a pdf file it opens with Sumatra but no restriction on.

Any ideas why is this inconsistency?

Thanks,


#2

Just to be clear,

  1. You’ve associated .PDF files with the portable copy of Sumatra on both PCs?

  2. You double-click a PDF on the Win10 PC and it opens in its portable Sumatra with restrictions applied, but when you double-click a PDF on the Win7 PC it opens in its portable Sumatra with no restrictions applied?

  3. What are the specific restrictions you’re trying to enforce via the INI?


#3

Most likely those are 2 different executables of Sumatra. Verify using process explorer the executable path for the case that has no restrictions and the verify that restrictions file exists in the same directory as executable.


#4

That’s exactly what I suspected as well, hence my first query. The OP should check whether the second PC has a previously installed version in addition to the portable version he copied over.

BTW those unfamiliar with ProcExp can use the good ol’ inbuilt Windows Task Manager too:

image


#5

@kjk @SumatraPeter You are correct. There was another executable of Sumatra in the Download folder and when I added the ini to it, it worked just fine.

Here is a strange thing. When I deleted the Sumatra.exe from the Download folder and then try to re-assign .pdfs to the new Sumatra location it didn’t work. It just ignored my action with no error message and kept the default Acrobat Reader. Wen I copied it back to Download folder I worked fine again. Download folder is not my preferred place where I would like to keep Sumatra. Any Ideas how can I change this?


#6

Ok, I think i got it sorted.

Windows gets confused about the filepath for a portable program.

For those who run into the same issue:

There is a Registry value that stores the Sumatra path.
\HKEY_CLASSES_ROOT\Applications\SumatraPDF.exe \shell\open\command\

“C:\Users\xxxxxx\Downloads\SumatraPDF-3.1.2-64\SumatraPDF.exe” “%1”

Changed it to:

“C:\SumatraPDF-3.1.2-64\SumatraPDF.exe” “%1”

And it works in the new location :slight_smile:

Thanks guys!


#7

Good to know you got it all sorted out. :slight_smile: