Problem with ExternalViewer setting for Bluebeam

#1

I have set the ExternalViewer setting to open up pdf files in Bluebeam as below. However when I click on the “open in bluebeam” option in the dropdown box, it doesnt open the file. The default open in Adobe works fine.

Not sure what is causing the code below to malfunction?

ExternalViewers [
[
CommandLine = “C:\Program Files\Bluebeam Software\Bluebeam Vu\2017\Vu\Vu.exe” “%1” -page %p
Name = Bluebeam
Filter = *.pdf
]
]

#2

It looks fine.

I would double-check and ran the command from cmd.exe to make sure that Bluebeam is in that path and accepts the arguments in that order.

#3

For every person it can be different there were 3 different versions on the older page ExternalViewers - Working Advanced Settings Strings
and none of those are the current version 2018 nor any of the special variants

As KJK has pointed out it is best to test outside SumatraPDF (use a simple cmd prompt) the try and understand how it differs inside the settings file where a %p replaces a page number and “%1” may not require the quotes

So place a pdf in an easy to find location such as c:\test.pdf then check what needs to change in a command line so that using my win10 64 bit version

“C:\Program Files\Bluebeam Software\Bluebeam Vu\2017\vu\Vu.exe” c:\test.pdf

will open that file once it does then next test is rename file to c:\name with space.pdf
now check that you can open the same file without error messages from the system about the file name breaks. then add the command into SumatraPDF settings with %1 for the filename test the file with spaces in the name works

If you get feedback along the lines of Error cant open file “name.pdf” cant open file “with.pdf” cant open file “space.pdf” then the file name needs “quoting” so change it to “%1”

Looks like Bluebeam Vu on win 10 accepts filenames with spaces so the following should be final working version of vu (2018+ will only be Revu)

“C:\Program Files\Bluebeam Software\Bluebeam Vu\2017\Vu\Vu.exe” %1