Problem during installation


Hello, i can’t install 64x version(description: installer is corrupted), x32 version works fine.
What should I do? :thinking:


When I run the installer.

Hi Georgy

Downloads can sometimes get broken for several reasons across a network.
I just checked the current 64 bit from
https://www.sumatrapdfreader.org/download-free-pdf-viewer.html
and it works well, so please try to download and run again.

I’ve also checked the 64 bit version and it works properly. Maybe the installer has some conflicts with other software. I think you should better check what may happen. I use two Adobe Reader tools on my PC: Sumatra and Adobe Reader DC. Once I had a conflict and could not install the newer version of Sumatra. Downloading and installing the standalone Adobe Acrobat version (https://get.adobe.com/reader/) has solved this problem. Maybe you also have some conflicts. Check antivirus or download the version again. Check if the soft requirements are compatible with your system.

Re-download and if it happens again, ensure your AV isn’t corrupting the file.

SumatraPDF-3.1.2-64-install.exe = 5,208,720 bytes

MD5 = 904a7dc26e6326191374082bd9f2f753
SHA1 = 593e9b0d96f07783df13f1b311548069961465fb
SHA-512 = 1d8724b841dc36bae77870668920b1460d7fa17cb577f2f2b002e171be84362e021c1b797ee32466ec33ff388c69d431dad68741a75b7da0be589ea45460e83a

(BTW these hashes I provided just reminded me of a suggestion I made 4 years ago!)

1 Like

Thank you all for your answers.The problem is solved by reinstalling windows :joy: Perhaps the reason is 1909.