Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Printing .tif images results in blank pages only

Hello,

I’ve been using SumatraPDF quite a while now and I am very happy with its features.

Recently, however, I experienced a problem:
(Testet with the current 32bit and 64bit portable version 3.2 with default settings on Windows 10 2004)

It is not possible to print .tif-files.
When I select a physical printer, eDocPrintPro, Microsoft Print To PDF or any other printer the result is only blank pages.

Can you confirm the problem and does anybody have a workaround for me?

Thanks a lot!

TIF is one of many graphic image formats like JPG, PNG, BMP, etc. It is used extensively by photographers, CAD operators and anyone else requiring a format where detail is more important than file size (TIF files can be BIG.) I tried printing a TIF file on ver. 3.1.2 and got the same result as you - blank page.

That said, I’m not sure that Sumatra is the best option for viewing/printing image files. There is a plethora of applications (many free and open source) that are designed to do just that. Microsoft Photos, which comes preinstalled with Windows 10, displayed and printed the same TIF image just fine. Other free programs include Irfanview and Gimp, just to name a couple.

Everyone, regardless their trade, should have a collection of specialized tools in their toolbox. However, if the only tool you have or know how to use is a hammer, every job begins to look like a nail. :slightly_smiling_face:

Russ

IF those TIFF files were not a problem in the past but only this past month then it is possible that if there were system updates you may need to update again or wait a few days till the next Tuesday one.
Looking at your windows system about version 20H2 should be something like 19042.870 with all the latest fixes.

I have seen many variants of TIFF over the past 35 years and some can be more troublesome than others. and as @Russ has pointed out it is a format favoured for working lossless with large graphics images usually at higher resolutions than needed for small everyday documents (which was one reason Aldus designed it).

Without a sample to see what’s happening e.g. are they high res or multipage.tiff I have to guess they may be exceeding the memory allocated to printing thus failing to complete the rendering to printer(s)

Just as a rough example I relatively quickly printed an odd size 10 page tiff that was about A3 in area (4MB) to A2 PostScript printout (611 MB) that failed to open thus I guess would be blank papers I printed to A4 which should be 1/4 the size but was it only halved to 306 MB why? however that opened well with all 10 PS pages visible.

I forgot your question asked for workaround

You can use SumatraPDF to save Tiff as PDF so my 4MB 10-page.tif is saved as 6MB 10-page.pdf the pages retain their odd 50.4 x 23.8 cm ratio but the image resolution contents are reported as a reasonable lower 96ppi.

That large page PDF prints eventually but the A4 printer output is itself now 600MB but is perfectly visible thus a capable printer should output the 10 pages.

Hi Russ,

thanks a lot for your input!
I use TIF to manage invoices because it supports multipage images and that’s how the files come from the scanner.
The files are monochrome and have a very small size.

SumatraPDF officialy supports TIF and therefore it would be desirable if printing these files would work again.

I need to be able to view PDF invoices (sent by mail) and TIF invoices (scanned) in the same program.

That is why SumatraPDF is the tool of choice and printing has also worked without problems in the past.

Let’s hope for a windows update that may fix the problem!

Matt

1 Like

Thank you for your workaround!

To your other questions: The files are very small in size (e.g. 34kb) as they are monochrom / multipage invoices.
I can reproduce the problem with any TIF file. So it is not a memory problem.

1 Like

Windows Update KB5001634 fixed the problem for me :smiley:

1 Like

In the scan settings, choose the output format .PDF and not .TIF - and you won’t have a problem with that. :slightly_smiling_face:
By the way, why scan in .TIF format? So when it comes to graphics, the .JPG format is usually used. :sunglasses:

We are running off topic since the problem was “printing not working” irrespective of the tif format that caused it.

That is true enough but it is not the best solution since it is usually a lossy format not suited to multi-page archiving.

The traditional format for (better or worse) Multipage Scanning has always been TIFF which can be jpeg encoded (but Jpeg introduces bad artefacts that distort when using OCR etc.)
Resolution is up to the scan operator but for B/W scan and Print 150 dpi is usually good enough however for Archiving 300-4800 may be required.

Tiff can be compressed and admittedly is highly variable compared to the separate jpgs but the fidelity of scans and combined pages is usually the preference.

If I scan a FULL blank page it is 2 KB as a 300 dpi G4 Tiff (using 1 MB RAM) with the blemishes but a whopping 159 KB as a 300 dpi Jpeg (using 25 MB RAM) with all the distortions Even If I convert to monochrome Jpeg it is still 50 KB (and the compressed memory storage does also drop to 1MB) . Multiply by hundreds of pages at a time and you can see the benefits.

The problem here is that when printing those multiple compressed pages get decompressed and expanded beyond the PC/Printers memories capacity.

If I scan a FULL blank page it is 2 KB as a G4 Tiff with the blemishes but a whopping 159 KB as a jpeg with all the distortions.
You think that 157 kB is a big difference, isn’t it? when today we commonly use a hard disk with a capacity of 500 GB and more … :grinning:

Thank you for your workaround!

To your other questions: The files are very small in size (e.g. 34kb) as they are monochrom / multipage invoices.
I can reproduce the problem with any TIF file. So it is not a memory problem.

For other landing here with a similar problem then NOTE the Original Post was fixed by the MicroSoft '21 March Updates.

There are many types of tiff coding even within single color / monochrome.
And even more types of printer. Model/Type
Print settings can have a large effect, as will user choices of working.
It also helps to know the exact version of SumatraPDF. we are currently on daily prerel 3.3.13415 6 as I speak :slight_smile:

If the files are consistently not opening then a typical sample would be welcome for analysis so as to check

A) current file handling
B) optimal printing advice

If the files are viewable it may be there is little SumatraPDF can do, as it has only one method for printing after 3.0, but I can test against different print drivers to try to understand why a fail may occur.