Forum moved here!

Home / Print to OneNote problems


Hi All

Occasionally I have a problem printing a PDF to Microsoft OneNote. I think it is related Sumatra PDF since if load the file Adobe Acrobat and try to print to OneNote 2016 it works just fine.

As a bit of background, OneNote is a popular note taking app for Windows. When it is installed, it also installs itself as ‘printer’ via a ]Print to OneNote option’ when selecting a printer when printing a document.

The symptom is the appearance of print out with a red X and a 'Pleaes wait while OneNote loads this Printout…"

Affected OS: Windows 10, 8.1 64 bit. OneNote 2016 32 bit. Latest version of Sumatra PDF.

Many thanks for any advice.



have not tried that combo however if your SumatraPDF is 64 bit I would try using 32 bit SumatraPDF ( perhaps the portable pre release = second entry on ) and see if it is a 32 bit issue as your one note is 32 bit


So thanks for the response. The SumatraPDF I’m using is 64 bit. I tried the 32 bit portable version you linked to, and the issue remains.

Adobe Acrobat will occasionally have the same problem too every once in a while on some documents, if I recall correctly, but it happens a whole lot less frequently. There must be a some weirdness in the OneNote printer.


Ok without finding a PC with your combination of apps, I admit i’m stumped, the only other variable may be the amount of data, images ? and the time it takes to collect and transfer as hinted by the “please wait”


Can you uninstall the 64-bit version and try the 32-bit installed version, just to check? (If you have customized settings you’d like to back up you can do so easily, since it’s just a simple text file.)

I’m also curious as to how it’ll behave if you right-click the 32-bit SumatraPDF.exe and choose to run it as admin.

Last thing I’d try if it were my system would be the older v3.0 with the Print as Image setting turned off (newer versions lack that setting and I wonder if it might be responsible).


I wanted to provide an update. Recently I switched to the 64 bit version of OneNote 2016 (the desktop client, not the Win 10 universal app), and the print to OneNote functionality seems to work more reliably. I am using the SumatraPDF v3.1.2 64 bit.

I don’t know if this is useful for debugging any problems other people may be having printing to OneNote, but I wanted to pass along the information in case.


Don’t know if this is still affecting anyone, but I just ran into the same issue. I only get the error when I try to open the PDF while OneNote is open. Sumatra works when OneNote is closed.