Forum moved here!

Home / PDF will not print to page size


I have a PDF file whose page size is fixed at 8.67cm W x 12.63cm H (that was how it came).

After loading the file in Sumatra and selecting the printer (Brother HL-L3270CDW color laser) I enter the printer preferences and select “fit to page”. My normal paper is A4. After hitting the print button all I get is the page printed in its original size. No matter what I do it will not change.

I then changed my default PDF app from Sumatra to Google Chrome and loaded the same PDF file. Now I can select the “fit to page” and it will print to the limits of the A4 page.

Can you suggest a solution?

PS. I installed another PDF reader (Javelin3) and it does accept the “fit to page” print modifier for the pdf file in question. If Javelin can do it then why can’t Sumatra?


It helps to know which version of SumatraPDF you are using

What happens when using other printers?
So here using both yesterdays version 3.2.12022 and 3.1.2 it is identical. I make no changes other than using Microsoft Print to PDF with “Fit” selected I get the expected A4 output.


I am using Sumatra PDF 3.1.2 - when I check for updates it says I am using the latest.

I only have one printer - a color laser Brother HL-L3270CDW and I can’t afford another.

The grab you show says that the PDF page size is already A4 so I don’t know where you get the 8.67 x 12.63 from. So it will automatically print at A4. If I bring up properties of the file I am trying to print the page size is 8.67 x 12.63 - not 21.0 x 29.7.

The fact that when I use Chrome (or an alternative PDF viewer - Javelin3) to view and print the pages they both correctly apply the “fit to page” option in the printer driver, so it can’t be the printer at fault. It is only Sumatra which won’t do it.


The source pdf tested WAS approx. 8.68 x 12.62 nearest I could get to same as the image inside it states.

The printing to “pdf” paper made it bigger to “FIT” the wanted A4, so If I send it to my HP paper printer it will enlarge to A4 and print to the edges if I select borderless.

I have updated the screen grab above to make it clearer that using a PDF printer will allow you to test real printer output over 90% of the time, without using carbon trees or ink.

If you are always needing to “Fit” then it is worth changing the default Settings > Advanced Options

    PrinterDefaults [
    	PrintScale = fit

Since the Print to PDF method did not work I changed the Printer default from Printscale = shrink to Printscale = fit.

After restarting Sumatra and loading the file again I found that it printed correctly to fit the A4 page.

While this appears to be the solution I am wondering why it all had to be so difficult. All other applications I tried to view and print the file to paper so that they came out filling the A4 page size did so automatically. They did not require defaults to be changed. It appears that if Printscale is set to “shrink” then it doesn’t matter whether the printer driver is set to “fit to page” this instruction is over-ridden by the Sumatra setting.

PS. With Printscale = fit I found that now when I used Microsoft Print to PDF the new file properties showed the page size as A4 and when printed to paper the page output was A4 size as well. So it appears that when Printscale = shrink (that was the default on my Sumatra installation because I had never opened the advanced settings before let alone made alterations) this setting over-rides the Print to PDF selection - whose default size is A4. Even though the new file which results from this operation shows the the page size is set to A4 it is not in fact true. Only when Printscale = fit does it become true.


I am not the developer, so cannot tell why SumatraPDF “default” appears to start at “shrink” rather than simply “none”. @kjk can the default please be changed ?
I have opened this request as

Note setting SumatraPDF default to “none” would not necessarily help in this case.

SumatraPDF is supposed to be driven by the “System default printer” so if your default printer is set to “letter” or “A4” then that should be the “default output”.

Then each printer driver can have default settings that interfere so you need to check for any advanced option settings to get 2 per page / scale or fit borderless etc. etc.

It appears the PDF driver has little to alter so is simple to check the advanced setting at print time is altered to “fit”

My HP driver has umpteen settings for glossy paper eco mode optimisation etc. but generally those default settings are OK. Other printer drivers especially for small label printing cause issues over placement on a virtual page.


The default printer is set to A4. It appears that Sumatra doesn’t take orders from the printer driver even though this should be the case.

Yes, the Brother HL-L3270CDW has all of those settings except borderless because it can’t print out to the paper edge due to practical limitations.

In all attempts to print to paper I selected the advanced option of “fit to page” in the printer driver but that was somehow over-ridden by Sumatra.


I have done a comparison using the same file in Acrobat DC Reader and its print options allows one to select the page orientation, ie. auto, portrait or landscape. If auto is selected the print output preview pane shows it being oriented in landscape mode even though the printer driver is set to A4 portrait. This is exactly how Sumatra perceives it and this is how it prints the file - landscape.

If I set orientation in Adobe to portrait the print output preview pane now shows it in the correct orientation and this is exactly how it is printed and just what I am looking for. Sumatra does not allow the page orientation to be selected in its print window whereas Adobe does. This appears to be a shortcoming and I am afraid I am going to have to switch to Adobe despite my preference for a smaller package.

I am attaching a grab of the printer output screen from Adobe with portrait orientation selected for the file in question. When Sumatra can offer the same options then I will install it again.


I cannot change margins either. Seems like I’ve tried everything, nothign works. I get 1 7/8" margins all around. The print it’s too small. This should be very simple, even Notepad can do this. IIRC the version is 3.2 or thereabouts.
Software is not what it used to be. Look at this forum software for example. Why does EDIT have to be a pic of a pencil ???


I’m using Sumatra, which IMHO is the best pdf (I hate pdf’s and prefer html or text) reader out there, especially because it allows me to choose screen background as I will not look at a white background all day long.
But I’m having trouble printing as the text only fills 1/2 the page, with nearly 2" borders all around. No matter what I try I can’t get the text bigger to use have 1/2" border. I don’t want to have to use a magnifying glass to read it !
pdf’s are a PITA. All they give us over html or text is pretty pictures.
BTW, after posting this msg, I’mdumped to a screen with only my msg. How am I supposed to get back to the Topic area ?
Also, why is there another box to my right that is duplicating exactly what I type over here ???


SumatraPDF was designed for viewing a variety of formats freely on screen
Adobe was designed to make revenue from initially one printer orientated file format (PostScript) thus Acrobat is well suported for addressing hundreds of different printers (especially Postscript ones)

After version 3.0 SumatraPDF relies fully on the Windows image printer method and its default settings.
So first the default page size in widows preferences dictates the taret paper size, such that if you were to send in metric terms an A5 to a default of A4 then it only covers 70% of the print area.
You would need Windows Default Paper to be A5 to get 100% coverage, However its not even that simple since the hardware has gripper margins to roll the paper without smudging the wet ink, In the days of yore those were where the tear off sprocket margins allowed “borderless” printing, and many users now expect that from their inkjet printers, but the drivers may overide such settings.
My current gripper default is 2 cm wide (roughly 7/8") but there are other limits to the pull in and eject that can vary the top and bottom values.

When you send a page with image margins to the driver it may add both the physical and image values in effect doubling the whitespace.

Furthermore the default scaling in SumatraPDF is “shrink” so if you frequently need to print small pages to larger Paper then in setting swap fit in place of shrink but that is just to set the default preference, thus saving you manually altering it each time.