Forum moved here!

Home / Not printing from command line



I am trying to get Sumatra to print some PDF files from the command line, executed by our Business Process software (from Orbis). The command we are using works fine when we are running it interactively at the command prompt on the server, however when it is executed from within the task, nothing prints out. I am using the latest version (I have tried both 32 and 64 bit) on Server 2012 R2.

I have checked various settings and configuration items. The task is being run under different user credentials, however when I set them to the same as the user on the server, we still don’t get anything printed. I have tried calling the exe directly, via a batch file and a VBScript, but nothing seems to work.

The printer is a network printer, and I am addressing it via the UNC file name.

I am at a bit of a loss in trying to make it work, and any advise would be appreciated.

Many thanks



Can’t help you with that. If it works from command-line but not when you execute it from your program, then the issue is in how you execute from your program.


Here is a link on how to do it using Powershell