Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Must restart SPDF for printer changes to take effect

I tried to print a PDF with SumatraPDF v3.3.3 64-bit on Windows 10 Pro 21H1 but the printer asked for Letter paper, while I only had A4.

Then I changed the Windows Printer Preferences/Properties to inform Windows that I actually have A4 paper.
The I tried to print again, but the same thing happened.
I had to close SumatraPDF and then open it again (with the same document). Now it printed on A4.

This may be a Windows limitation, but I report it just in case.

So the point: changes in Printer Preferences are not used in SumatraPDF unless it is restarted.

Hi David
It is possible, for either Command Line Printing or Print from GUI SumatraPDF to only query the system default once on starting, so as you have noticed changing default after start could become an issue, however you should be able to change printer preferences between paper choices.

My Default is A4L so when printing I would need to set preference to Portrait Letter if so needed, and using todays pre-release that’s what it changed to without me needing to exit to change from my metric default.

It may be a 3.3.3 limitation so I always suggest to double check current pre-release as a first step.

had the same issue until I updated the SumatraPDF