Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Links inactive on PDF pages on CD/DVD

Hello, I bought a PDF’s on a CD version of a workshop manual in 2013. I have used it on several occasions, the last of which was in early 2020.
In the last few days, I was trying to view a particular instruction page. I loaded the CD and opened the “Start Here” page as usual and noticed it was showing page 1 of 1 instead of page 1 of 7232 pages. I could not use any of the page up/down arrows, or click on links or bookmarks to get to the required section or pages like I could previously. I had to open each pdf individually to read what it covered; then close it and open the next likely page.This is time consuming with over 7200 pages to work through.
As I did not have this problem previously, I wonder if Windows 10 or the PDF reader updates has caused this issue. All other multipage PDF’s stored on SSD and SD cards etc open and can be perused as normal.
Any help will be much appreciated!!

Unknown which version you are using but recommended sequence to try/test is

First latest Daily (portable) in case a bug WAS fixed.
Second unpack and try one of version 3.1.2 portable.zip
If that works raise a regression report at Issues · sumatrapdfreader/sumatrapdf · GitHub

Thank you very much for the prompt response!!
I used Sumatra V3.1.2 and everything works as it did originally. The information on the CD indicates that it was created on 15/04/2010 with a very early version of Acrobat (Distiller5.0.5) and modified on 01/07/2012. I also noticed the application listed was 'PScript 5 dll. version5.2.2
All of that was well beyond my abilities to comprehend; other than the very old version of Acrobat used to produce the PDF document, and it made sense that I needed to use an older version of a PDF reader.
Thank you very much again for your guidance.

Thanks for the feedback but just to be clear this end
Did you try a newer version and it failed to read the file on CD/DVD but 3.1.2 works
Did you try to copy file from CD/DVD to hard drive and see if it works there with newer version.

In other words is it the file that causes the problem or is its location on DVD that causes new version to not work?

I have tried several versions, reading large files on old DVD/CD without problems.
But then again there are many types of drive and disk formats I did not test.

CD/DVD, just like magnetic media, will degrade over time, so if historic file(s) are critical to you you need to keep duplicates (backup)

To clear up questions on whether the CD was at fault, I copied it to a new Verbatim disk and that would only work with the early version of Sumatra and Acrobat reader version 9. I also moved a copy onto my hard disk (NVME SSD) and the result was the same. All other reasonably recent (up to 3 to 4 years old) PDF’s are accessible with all versions of the readers that I tried. I can only put it down to an incompatibility with the original set up of the Workshop Manual back in 2010 and modified in 2012.
I wil also follow your advice in backing up all my old CD’s and DVD’s with any important documents, music, photos etc.
Thank you again.

Thanks again,
Since it seems to be down to regression with one type of file (in this case an older manual, but odd behaviour could manifest in others newer) it is always helpful to look at examples for debugging current SumatraPDF. If the file is commercially sensitive you could send a copy by email to developer with reference to this discussion.
If the file is available to wider public use then a link here to a drop box or similar web copy would do. (links should get put on hold for spam checking)