Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Latest SumatraPDF 3.2 flickers on various Latex-generated files

Hi,

I’ve recently updated to the latest Sumatra 3.2 x64 on Windows 10. Since updating, the program often flickers on various PDF files (tried mostly with Latex-generated files). The display flickers quickly between proper display to displaying white rectangles, as in the image below.

Thanks!

Shlomi

Nothing can be done without a sample file that shows where you see rectangles and any hints as to non standard hardware settings e.g. main monitor at 100% scaling, either a file accessible from the web or uploaded to github

System configuration. I’m using a latest Windows 10 Pro x64 on a HP440 ProBook G5 laptop. This machine has a fairly standard graphics card, Intel UHD Graphics 620, to which an external Dell P2417H monitor is connected via HDMI. I tried switching to the internal display once, and the display problem I had remained the same.

Windows settings. Under System --> Display --> Scale and layout, the size of text, apps and other items is set to %150. Under Advanced scaling settings, I’ve just turned on Let Windows try to fix apps so they’re not blurry – will post here if the problem will disappear as a result.

Here is another sample image demonstrating the flickering rectangles problem.

The screenshot was captured using this Latex-generated test file, with Sumatra PDF v 3.2 x64 on a 200% zoom factor. When using a 300% zoom factor, the text itself sometimes dances. These problems seem to occur less on a lower zoo factor of %100, more on higher zoom factors.

Thanks!

Shlomi

Thanks for a MWE the file seems to be valid and conventional LaTeX output without any noticable differences in areas.

I tried many combinations of your windows settings on my current Winx64 version 3.2 with/without second screen active using numerous zoom actions however I could not at any time replicate any dissapearance of text.

I have to therefore suggest it is possibly a graphics driver issue in your current build of Win 10, It may be worth checking if HP (and only from the HP official site have any update drivers for recent Win 10

If you can duplicate the problem using a portable copy of 3.2 (without the second monitor attached) then it would be worth opening a ticket with HP to see if they can determine where the problem lies on their hardware/driver combination.

Thank you @GitHubRulesOK!

My laptop already has the most recent drivers by HP (I keep it updated). These display issues started immediately after I updated to Sumatra v3.2, and appeared in no other program (including other PDF readers) and in no older version of Sumatra PDF (I’m a heavy user of Sumatra, for the last ~2 years).

What I did notice in the last few hours, however, is that turning on Let Windows try to fix apps so they’re not blurry in Windows Settings seems to have solved the problem. Did you try duplicating this issue with that Windows setting turned off?

Thanks for the feedback I must admit since you had suggested it as active :slightly_smiling_face: I left it on and did not try it off

I switched on the Let Windows try to fix apps so they’re not blurry Windows settings just before publishing the detailed post above, earlier today. Haven’t experienced these issues since – will report should I do.

The HP ProBook 440 G5 also supports switchable NVIDIA GeForce 930MX graphics, so are you sure you don’t have that variant and if so, the discrete graphics isn’t in use?

I cannot replicate the issue either here on any of my desktops or laptops (no HP ones however), no matter what that Windows ‘fix blurry apps’ setting is set to. Since the OS setting’s basically a workaround, the underlying issue with the software at fault still needs to be fixed. Thus if you want to follow up further I suggest downloading the latest and then successively older MuPDF for Windows packages (it’s the display engine for Sumatra) and viewing your file with mupdf.exe and mupdf-gl.exe. If you can replicate the issue with any version of these programs, I suggest reporting to both HP (plus optionally Intel/NVIDIA) and Artifex (MuPDF devs).

Thanks @SumatraPeter. I double checked, my computer only has an Intel UHD Graphics 620.

Sumatra 3.2 now exhibits the flickering rectangles problems even with the Let Windows try to fix apps so they’re not blurry Windows settings turned on.

I tried a handful of MuPDF versions (0.6, 1.0, 1.4, 1.15, 1.16 and 1.17), on several files each, both with and without that Windows setting. Did not notice any flickering or text dancing with MuPDF (though old MuPDF do display blurry text). On some of the files Sumatra did flicker at the same time I was testing with MuPDF, both with and without that Windows setting.

My hunch is that there’s an illegal memory handling Sumatra is doing (e.g., dereferencing a dangling pointer). This is based also on crashes my machine had every now and then, which seemed to be triggered by older Sumatra versions (didn’t bother to report those).

If you could point me to the code in Sumatra painting white rectangles / clearing screen regions on page redraw, I’d be glad to take a look.

If we are trending to SumatraPDF rather than HP as the cause the best action at this point is to escalate it as an Issue to GitHub where it can be reviewed as a Developer issue

Hi, I just wanted to add that I am having very similar issues on a Surfcace Pro with Windows 10. In my case I have noticed that it is mostly AutoCAD generated PDFs that cause the issue (of size A1 or more)

When I zoom in too far on a Panasonic TV the PDF flashes in rotating rectangles. Roughly what I mean is that the PDF page is divided into quadrants and the content flashes in succession in each quadrant, leaving only the background visible. This behaviour only starts when zooming in (I haven’t discovered more detailed patterns yet), and as I zoom in more the frequency of the flashing increases. Interestingly, the size of the quadrants or sectors does not change as I zoom in, so if zoomed in enough the whole screen just flashes as the whole quadrant is filling the screen.

Ithink this has very much to do with some interaction between Sumatra, and Windows’ terrible handling of scaling and anti-aliasing. Playing around with the compatibility settings of Sumatra (under change high DPI settings) can worsen the problem, causing even A4 Word generated PDFs to flicker.

Another observation pointing to memory issues is that the problem seems worse when I have many tabs open. If I have only a single drawing open and the following setup the problem dissapears completely:

  • The “Use this setting to fix scaling problems…” windows option under “change high DPI settings” unchecked.
  • The high DPI scaling override setting checked and set to “System Enhanced”.

When opening Shlomi’s test file and zooming in I do not get any flasing but do get the “dancing text”, the frequency and pattern of the dancing text follows that of the flashing describe above. If I zoom in far enough the application crashes.

@Shlomi
@dieswartkat

There has been a recent update to deal with one source of “flickering”
Can you please see if using the latest dailybuilds removes the problem for you.

Hi, I can confirm that the flicker problem disappeared for me with the daily build SumatraPDF-prerel-13114-64 (v3.3.13114 64 bit)
Thanks a lot for your hard work

1 Like

I tested the portable 13114-64 build (SumatraPDF-prerel-13114-64.zip) for a while on several Latex-generated files, in several zoom factors each. The flickering and “text dancing” have just about disappeared. There is a momentary flickering when a page is being rendered. Yet, it ceases once rendering is done. This seems to solve the problem of v3.2. With that said, the older v3.1.2 seems to have even less momentary flickering on page rendering.

Thanks for your efforts!

1 Like