Latest beta -> Send by E-mail ... doesn't work on my machine

Sumatra PDF beta v. 3.2.12014 x64

On my Win 7 Pro x64 machine, I use an old version of Thunderbird. It’s set correctly as my default (and is my only) Email client.

Also, Sumatra PDF is set as my default PDF program.

When I have a pdf doc open and click File -> Send by E-mail …, nothing happens.

Thank you for your help.

Do you not get any hint !
I at least see this with the latest 12016
image

Thank you very much for your reply.

I’m not quite sure where you got “the latest 12016”. The beta download website shows this.

In any case, no, I didn’t get any error message. However, when I clicked the “Send by E-mail …” item in the list, I noticed my cursor “jumped” for about half a second. That’s all that happened.

Again, thank you for your reply.

Best regards,
JoeyG

Much of the error handling is down to Windows

The message I show earlier above is one on an older modified Windows 7 installation which gives no clue as to what’s wrong.

The later version today from https://www.sumatrapdfreader.org/dailybuilds.html should not behave different to the one you are using from Midnight

100% Newly installed Windows 10 and the latest version give this much more informative message as how to fix it

image

In both cases SumatraPDF simply calls the system in the background with the filename and it depends how the system handles the call such that Windows should respond with some error message.

Thanks for your follow-up. I’ve now got 12016, but it hasn’t changed anything.

I’m not really worried about an error message or the lack of one; I’d simply like to be able to use Sumatra’s menu item to send files via email.

I’ve checked, and Thunderbird is my installed, default email program.

Do you have any idea why Sumatra and Windows can’t “find” it?

Thanks again.

Basically SumatraPDF relies on passing a standard message to Windows to use the operating system default as described here https://support.mozilla.org/en-US/kb/make-thunderbird-default-mail-client the behaviour should not have changed since version 3.1.2 and on my system I get exactly the same windows error response since there is no default email application.

It may be that SumatraPDF is sending the correct message to the Windows system but the windows email protocol handler is not echoing an error back from thunderbird ?

There are some support hints on the page above that may help, however, note there are no settings in SumatraPDF application to change it from using the Windows System as the default handler. If windows is configured correctly, it simply should work.

One factor that could be blocking SumatraPDF passing a valid filereference is the file path and or name so putting a simply named test.pdf in a simple root folder like C:\users\test.pdf then open and try sending that.

Hello again, and thank you for your ongoing support.

“…so putting a simply named test.pdf in a simple root folder like C:\users\test.pdf then open and try sending that.”

Thanks, but I’m afraid it didn’t work.

I’m not sure how to tell whether Windows is set up correctly or not, but I can tell you that my browser (Pale Moon) correctly finds Thunderbird when I click the command File -> Email Link …

Again, thank you for your help.

Does it work if you’re in explorer and use context menu Send To / Mail recipient ?

This code in Sumatra didn’t change, ever. It does require the client to be registered with Windows in the right way.

In daily builds we’ve added File / Show in folder menu item so you can use that and then use context menu Send To.

Just to confirm what @kjk the developer is describing is that SumatraPDF in the background uses the same method as shown manually here so if that does not work then SumatraPDF can’t be expected to work either.

image

I have a feeling Windows 7 works differently than Windows 10, but anyway, I fixed it. I must confess I got some tips by using a search engine. The “trick” was setting Thunderbird so that it would work with Internet Explorer v. 11.

In IE under Internet Options, there’s a tab called programs. Even though I had already set Thunderbird as the default email program using the Windows Default Programs interface, IE didn’t work until I set it in this tab. And when it worked in IE, it worked in Sumatra, too.

The crazy thing is that now when I right-click a file in Windows Explorer and then SendTo, There’s no option to send the file via email, but that’s OK.

At least Sumatra works correctly now. I’m going to reboot my computer now, though, just to make sure. :wink:

1 Like

The default message shown above should be the same for windows 7 and windows 10

In windows 7 the setting is easily found as described by JoeyG in Internet Explorer Internet settings

For windows 10 users this in turn leads to default apps where you could point to Thunderbird or other email application (NOT SumatraPDF)

Well, I guess I got happy too fast. :smirk:

Now that I’vce re-booted, clicking “Send via Email” still sort of works in Sumatra and IE, but only sort of. Now, clicking one or the other opens the Thunderbird program, but not the “Compose” window, which essentially defeats the purpose of the whole thing.

Just in case you’re doubting whether my computer is set up correctly, please have a look at these two screen shots.

I would be very grateful if someone can show me where the problem is.

Thank you for your ongoing help.

Unfortunately Not using any e-mail app for at least 10 years since I always uninstall the windows 10 app and use web-mail

I cant help other than to suggest some Thunderbird forum like forums.mozillazine.org/viewforum.php?f=39 which has old posts or current support at https://support.mozilla.org/en-US/products/thunderbird

OK. Thank you very much.