Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Latency Writing Annotation's Content [Fixed in 3.4.14060]

Hello. I’ve been using Text annotations and I’ve been finding a latency behavior every time I write into the Content field of an annotation in the Edit Annotations window. It appears to happen in both Highlights and Text annotations. If I write anything at any speed other than very slow, the letters appear to lag and take quite a while to all appear, one after another, in the Contents field.

I was using a previous pre-release version when I first noticed this. I updated to the current daily version, 13702, and this behavior is still present. I haven’t experienced this sort of thing with any other program, and I don’t believe it would be something related to an overusage of computer capacity as I normally only use Sumatra with no other considerable processes in the background. I have tried this with both large and small PDF files, and the behavior is the same. Is this a known issue, or would there be some way of solving it? Thank you.

Need to be reported as an issue, ideally with a sample file, at
GitHub - sumatrapdfreader/sumatrapdf: SumatraPDF reader

However I have a very slow machine and just now on a bad 2 page PDF did not notice a problem (but I am a one fingered typist)

1 Like

I see. Knowing that the issue is only on my end, I’ll try and see if I can fix it before opening an issue on GitHub. Thank you.

Perhaps try a different rig are you 32bit or 64? I note problems on Win 7 32bit.

Win 7x32 is slower so I can see what’s happening there. There might be a valid issue since on each key press I see the body refresh, If that page was slow to render there could be a corresponding latency for next character.

I have opened an Issue to track your observation

1 Like

I’m on 64bit Windows 10. It seems odd because I’ve tried several other programs to see if I get a similar behavior, such as Notepad++, Microsoft Word, Notepad etc., but they’re all working just fine. I don’t know if this helps, but I’ve tried the 64 and 32 bit portable and installed versions, and they all have the same issue.

Thank you for opening the issue. I hope a solution can be found.

I would guess it would be more noticeable in larger graphics files or if heavily compressed images, see if its less noticeable annotating in a smaller single page PDF. You can simply discard changes after testing in such a file.

1 Like

I exported a single blank page from Word as a PDF. Created a single text annotation and wrote into the contents field. This input latency is just slightly less noticeable than when compared to the other books I was originally annotating, but it is still present.

1 Like

One last suggestion is do you have an Anti-Virus (or other keyboard monitor like Keyboard enhancements) checking all activity?

The way to check that, is go offline and temporarily stop such activity monitor, test for improvement then ensure it is back on before returning online.

I do not have any anti-virus programs aside from Windows Defender already native to Win10. I went offline, then turned it off, but saw no change in the Content field latency behavior. I don’t have any other keyboard related programs.

1 Like

Wanted to chime in that I have been having similar issues. Monitoring task manager for Sumatra’s activity while typing a comment shows no real change in CPU, memory, or disk activity usage.

Given @sticke4’s reply, I just wanted to update that I am still having this same issue while using the most recent pre-release build 14058.

Please try build 14060 or later, it should be better (

1 Like

I’ve just installed build 14060 and the problem is indeed fixed. Thank you!

1 Like

Please see above

I’ve also tried the new build just now and can confirm that the problem is fixed for me as well. Thanks so much!