Forum moved here!

Home / Inverse-search reset


Hi, this is my first post, I hope this is appropriate, I have benefited very much from the app and the discussions on this forum so I thought I would contribute by raising the problem I have encountered. I have set up notepad++ with sumatraPDF, and although it works well, it has been somehow temperamental, namely, the inverse search command keeps resetting to a value which does not work. It should be “C:\Program Files\Notepad++\notepad++.exe” -n%l “%f”, but lately it keeps resetting to "C:\Program Files\Notepad++\notepad++.exe (the quotemarks don’t even close). I expect that it is cutting it somehow, but cannot find a consistent reason as to why. I keep resetting it to the correct command, but it won’t stay that way. On another computer I use it has never been reset. Is there any way I can “set” it so that it never changes?


That has been reported very occasionally by others
There seems to be no reason although it is one of several volatile settings.
It is easy to reset it once when needed via a command line (it should not be set every day just when it goes wrong ?)

so in a reset.cmd file add using standard double quotes like this with the correct path to your SumatraPDF

   "C:\Program Files\SumatraPDF\SumatraPDF.exe"  -inverse-search "C:\Program Files\Notepad++\notepad++.exe"  "%f" -n%l

A potential cause is the occasional edit and save of the advanced settings file in an editor that upsets the txt encoding. I always use standard windows notepad as the default which uses windows CRLF and UTF-8 with BOM