Inverse search: only part of filename passed on


#1

I’ve been succesfully using Sumatra PDF together with Sublime Text 3 for half a year now, but now, the inverse search has suddenly stopped working. The .tex files I am using are located in my OneDrive for Business directory, which is "C:\Users\me\OneDrive - InstitutionName\".

As mentioned, the inverse search has worked perfectly for some time, but now Sumatra PDF cuts off the file name after "OneDrive -", so Sublime then proceds to open a new file "C:\Users\me\OneDrive -" instead of my .tex file. I have tested that Sublime opens the file at the correct line, so the ":%l" part is included after the shortened file path. I have verifyed this by changing the inverse search command to notepad "%f:%l", which results in a prompt to create a new file.

The inverse search command I use, which worked for quite some time, is
"C:\Program Files (x86)\Sublime Text 3\subl.exe" "%f:%l"

Sumatra is launched from Sublime Text, using the following command (according to the Sublime console):
"'C:\Program Files\SumatraPDF\SumatraPDF.exe' -reuse-instance -forward-search 'C:\Users\me\OneDrive - InstitutionName\currentFile.tex' 86 'C:\Program Files (x86)\Sublime Text 3\Data\Packages\cache\main.pdf'"

Any idea on how i can fix this?


#2

Never mind. After trying to troubleshoot this for multiple hours, it started working again the next minute after i created this post


#3

Thanks for confirming it was a glitch, your settings as shown look ok, you can check in the advanced settings what the current value of inverse search is, there is always the possibility that file was affected for a while, though it would be odd unless using an editor that saved in a different bit format.

Note you don’t need the depreciated -reuse-instance that should always be set in advanced settings file to be = true


#4

I’m sure there’s some corollary to Murphy’s Law that’s applicable to such cases. :slight_smile: