Internal links in a PDF doesnt work


#1

Im trying to read a textbook in PDF format that have many hyperlinks between it pages, however the links doesn’t work at all but an icon of a hand appear when I hover on a link.

There is a way to fix it? I have done the standard installation of the program in windows 7.

P.S.: I had read some other topics in this forum about non-working links to external content, however in my case these links are just between pages of the same PDF.


#2

Have you tried another viewer (or even a browser if you don’t have another PDF viewer installed) to confirm that the intra-document links actually work?


#3

Yes, Im using for this book other PDF reader. I tried Adobe reader and X-Change reader and it works normally.

UPDATE: it works in other PDF readers but still it doesn’t working totally right. It seems that the PDF is not so fine. Fortunately I found a different PDF of the same book who hyperlinks works in sumatra.

I guess we can close this topic, sorry for the inconvenience and thank you for your patience.


#4

Without taking a look at the actual PDF it’s very difficult to comment further.


#5

For reference or testing:

http://gen.lib.rus.ec/book/index.php?md5=3CA5CB973DC5998979FA49C1F3C097A6

this is the not-very-well working PDF (the internal hyperlinks doesn’t work in sumatra and in other PDF readers works not very well), and this is a different copy that works fine in all tested PDF readers (including sumatra):

http://gen.lib.rus.ec/book/index.php?md5=2F37E55C5A9B4F14C5E64697DCF71306


#6

Got the same results as you, that is to say in the first file some links work while others seem to be broken. Since these are all pirated copies who knows what’s been done to them in an effort to remove any identifiable information/metadata. Since Sumatra itself seems to be functioning fine, as you rightly said there’s nothing more to be done here.