Installing SumatraPDF was affected by Breaking Default Apps on Win 10 ver. 1803


#1

HI,

Just want to report bug regarding to installation on Windows 10 ver 1803. It seems installation of Sumatra PDF cause ‘Set Default by App’ crashed (refer to below screenshot)

Later I check on Windows Event Viewer and got this error (same time as my settings app suddenly closed / crash)

Faulting application name: SystemSettings.exe, version: 10.0.17134.1, time stamp: 0x2a3c4e62
Faulting module name: ntdll.dll, version: 10.0.17134.1, time stamp: 0x207580e2
Exception code: 0xc0000409
Fault offset: 0x000000000008aa2f
Faulting process id: 0x14e0
Faulting application start time: 0x01d3f5612ca3932e
Faulting application path: C:\Windows\ImmersiveControlPanel\SystemSettings.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: fc556e6e-2c28-42ec-86ce-7ea5a4fb6627
Faulting package full name: windows.immersivecontrolpanel_10.0.2.1000_neutral_neutral_cw5n1h2txyewy
Faulting package-relative application ID: microsoft.windows.immersivecontrolpanel

Reading from Reddit Thread https://www.reddit.com/r/Windows10/comments/8cy51p/windows_10_settings_crashes_when_selecting/dz2qczz/ Someone pinpoint that SumatraPDF may be the cause, I try to uninstall SumatraPDF and suddenly Settings default apps is working without crash, So I’m pretty sure that installer do something which broke it.

Environment:
Windows 10 64-bit
SumatraPDF Stable and Pre-Release

Anyway this didn’t happen if I use SumatraPDF portable edition, so maybe some installation break something

Thank You,
Hadi Susanto


#2

So far I see no conclusive proof that it’s Sumatra’s fault, since as I noted on GitHub people without Sumatra installed are experiencing this as well:

Considering that Sumatra has not been updated but Windows has, my money’s on MS having broken something. Have they even bothered to respond to these reports?


#3

Hi,

Thank you for informing me, Hope MS can fix these things, anyway I should stick with portable version for now.

Thank You


#4

@kjk
I have sometimes and sometimes NOT seen this issue

Using current Windows 10 I do not see this on any of my 32 bit 1803 versions
using current Windows 10 it still seems to be an issue on 64 bit 1803 (as at 18-05-24=17134.112) I think it may be a problem with the way MS handle unexpected settings only in a 64 bit environment

[UPDATE] this registry change should no longer be needed see my updated posts below and the folowing thread on github https://github.com/sumatrapdfreader/sumatrapdf/issues/1019

My previous fix was to simplify SumatraPDF description and capabilities to a single word
this file worked for me on Win 10 x64 (n.b. should also work on 32 bit IF needed)

open notepad and cut and past the following text the firstline is REGEDIT4 add a couple of blank lines after the “.fb2z”=“SumatraPDF” at the end for luck :slight_smile:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\SumatraPDF]

[HKEY_LOCAL_MACHINE\SOFTWARE\SumatraPDF\Capabilities]
"ApplicationDescription"="SumatraPDF"
"ApplicationName"="SumatraPDF"

[HKEY_LOCAL_MACHINE\SOFTWARE\SumatraPDF\Capabilities\FileAssociations]
".pdf"="SumatraPDF"
".xps"="SumatraPDF"
".oxps"="SumatraPDF"
".cbz"="SumatraPDF"
".cbr"="SumatraPDF"
".cb7"="SumatraPDF"
".cbt"="SumatraPDF"
".djvu"="SumatraPDF"
".chm"="SumatraPDF"
".mobi"="SumatraPDF"
".epub"="SumatraPDF"
".fb2"="SumatraPDF"
".fb2z"="SumatraPDF"

Save the file as

SumatraPDF Capabilities.REG

(it must be .reg NOT .reg.txt)

when you double click the file Registry Editor should ask “Are you sure you want to continue”

you should only trust me if you think I’m a liar (joke)


#5

I just registered here to thank you. That solved the issue for me. Thanks a lot!


#6

Hi!

This might be caused due to the upgrade or missing ntdll.dll module.
I would suggest you to initiate SFC scan and check if it helps.
Please refer to the below article to initiate SFC scan and know more about on this Microsoft page

[Moderated to remove a suggested site with exceptionally low WOT rating]


#7

Tried running SFC on both 32 and 64bit to retest latest behaviour, whilst it repaired some errors on one 64 bit installation it did not make any difference to the default app page crashing,

[UPDATE]
As a result of testing several recent versions of win 10 latest win 10 x64 (build 17134.137) I can no longer observe this misbehaviour, it appears Microsoft have recently changed something and the installer now works for me across the board on win 10x64 after reboot without any noticeable problems

please note IF you still have this issue, you will first need to confirm if KB4284848 was installed without failure