Installation omits virtual printer


#1

Hi there, I’ve been using SumatraPDF, both reader and virtual printer, successfully for several years on my good old 32 bit Laptop under Windows XP, 7 and 10.

Now I moved to a Lenovo Thinkpad with 64 bit Windows 10 and after installing SumatraPDF I couldn’t find the virtual printer in the printer list any more while the reader worked perfectly. I tried both SumatraPDF 3.1.2 64 bit and SumatraPDF 3.1.2 (32 bit).

Does anybody have an idea what could have happened or what I can do to fix this ? Thanks in advance. Leo.


#2

Sumatra PDF has only ever included a PDF viewer browser plugin for Firefox (now deprecated and no longer installed), an optional Windows Desktop Search iFilter and a thumbnail preview handler. No virtual printer has ever been part of Sumatra PDF.

You need to identify what virtual printer you had installed on your old system and install it on the new one in case it is compatible. BTW Windows 10 includes its own “Microsoft Print to PDF” virtual printer by default, in addition to the older “Microsoft XPS Document Writer”.


#3

Thanks for your quick answer. I confused SumatraPDF with pdfcreator. Mea culpa. I apologize for the inconvenience. Regards Leo.