How to stop Sumatra saving every .pdf file


#1

Sumatra is my default pdf viewer in Windows 10.
However, it persistently saves every .pdf file I read in my downloads folder which is now overflowing.
I can’t find anything in Settings.
Is there a way to prevent this, please?
Is it Sumatra or is it Windows 10?


#2

That’s a good one, SumatraPDF is set to open any PDF you download
Windows 10 needs to download the file to somewhere for Sumatra to open it
Thus I would contend it is Windows 10 that is following your instruction to download and open the file
Note the alternative is that you let your browser “download” the file to a temporary location and it calls Sumatra to view it then if the browser settings are set to delete temporary files on closure, it would reduce some if not all the transient files.


#3

Thanks for that.
I understand that the file has to be downloaded somewhere on my computer but, until recently, I was able to read the file without having the necessity to save it.
That certainly suggests that Windows 10 (or changing my browser to Opera) has changed something and I will check all the settings to see if I can revert to automatically deleting the file after Sumatra has done its stuff.
Thanks again.


#4

Ok that’s an issue for opera forums but I think it may be you need to check “security” options such as cached images and files see


#5

Thanks - that’s great and I’ll deal with that now.
I also found a Windows 10 setting which clears files older than 30 days from the Downloads folder.
So a combination of both methods should cure the problem.
I’m very grateful for your help.