Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

How to eliminate the small gap from tabs to the top of screen

There is a small gap between the tab bar and the main app frame, as show in the screenshot:

which makes the tabs hard to click when maximized, is it possible to eliminate this gap through some custom style or something?

For comparison, Chrome’s tab bar doesn’t have this issue when maximized, just move your mouse all the way to the top of the screen and click, the corresponding tab would be activated.

Interesting that most previous requests were to increase the ability to drag and resize window so looking at how Microsoft do it Internet Explorer was a massive grip margin see right part of image but Chrome version Edge is now smaller but still present.

@GitHubRulesOK: Note that he’s talking about a gap even after maximizing the Sumatra window!

For the record I just tested with the latest stable ChrEdge and latest Sumatra prerel-13202-64 and neither had any gaps on top of the tabs when the window was maximized, just as expected.

@old9: What’s your current monitor resolution and Windows scaling level?

Thanks, I didn’t know this is resolution/scaling related.

I have a multi monitor setup, I did some test and find that on my main monitor (3840x2160@150%), there is no gap and it works as expected, but on my secondary monitor(1920x1080@100%), there is a gap.

I’m using Sumatra 3.2 64bit, Windows 10 2004 19041.630

@SumatraPeter
Mia culpa I had not read the question properly, but agree that maximised on both screens works as expected i.e. NO gap on secondary 1920x1080 neither using 3.2 nor latest daily. On 10x64 20H2O (19042.630)

For what its worth both my screens are 100 % and primary is smaller than secondary, thus issue might be a result of a larger primary, but don’t see why

I did try starting 3.2 on primary at 125% (max I can go) then move to 1920x1080 @ 100%, before maximising, but again no gap.Also tried starting on second screen maximised and pre maximising, both cases no gap.

'Twas an educated guess, but good to have it confirmed. :slight_smile:

Does it happen only when you move the Sumatra window from your primary to secondary monitor? How about if you set Sumatra to open directly on the secondary monitor? Also, does un-maximizing and re-maximizing the window make the gap disappear?

Like GitHubRulesOK I too cannot replicate this, but seems to me it might be the fault of either Windows and/or the graphics driver. However @kjk should be able to shed more light on whether Sumatra’s window drawing code is somehow responsible, or perhaps some sort of workaround can be implemented.

I tried to launch Sumatra on my main and secondary monitor, and then drag to the other one, the results are the same, no gap on the main monitor and a gap on the secondary, and in both scenarios re-maximizing does not make the gap disappear.

I changed the scaling ratio to 150% on the secondary monitor, and the gap disappears, then I changed it to 125%, the gap reappears, then I tried 175%, 200%, both no gap. It seems that the gap appears when the scaling ratio is smaller than the main monitor.