Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Error: Can't open files from a non-admin process

Laptop details: I am using Windows 10 OS. Sumatra PDF is my only PDF reader. I am the owner/admin of my laptop and there is only one login account.

Error Information: Sometimes, when Sumatra is running, i.e. there are one or more files open, and I try to open another file from my file explorer (double click on the file), I get this error message “SumatraPDF is running as a admin and cannot open files from a non-admin process.

This doesn’t happen always, i.e. usually, I can open a file from my file explorer when Sumatra is already opened with one or more files.

Pease check the attached image for the error message. Sumatra_error

This is a standard Windows behavior.

For security reasons an elevated (admin) process cannot accept input (e.g. files) from non-admin user.

That’s what the error message is saying: you must have started sumatra when you were an admin, so it inherited your admin credentials but now you’re not running as an admin and trying to send it a file.

Which windows doesn’t allow.

Clarify if you are running a different explorer than the Initial admin driven native MS file explorer. e.g. a 32bit file explorer app may be attempting to cross 64bit UAC boundaries

Thanks for replying.

I don’t understand how I could be starting sumatra as an admin and then open files as a non-admin. So please allow me to explain a bit more:

I am the only user, the admin of my laptop. I just open my laptop and open (pdf, djvu, etc.) files by double clicking the files. The files open in Sumatra automatically as it’s my default and the only 3rd party PDF reader. I don’t open Sumatra and then open files from inside the app.

So I don’t understand how I could possibly open Sumatra as an admin and then open files as a non-admin.

Also, the problem vanishes if I close the opened/running Sumatra app and then try to open the files, the files open normally (which wasn’t opening and showing error when the sumatra was already running). The problem occurs sometimes when I have Sumatra opened (with one or more files) and I try to open one more file.

If it matters, Sumatra is not a startup program in my laptop. It opens only when I click on the files.

Thanks for replying.

I am the only user and admin, and I use my file explorer (the default in Windows 10) as a normal user. My OS is 64bit.

Is there a possibility that my 64bit OS is opening a 32 bit file explorer without my knowledge?
(I don’t know if it’s possible; I don’t have enough technical ideas.)

No if your explorer is 64 bit then there should be no problem, my query was in case you were using DoPus / Total Commander or some other third party explorer.

So from the sound of it there is no rational reason for the non-admin error on occasion, however it is not normal from my experience using both non admin or admin login.

I have the same issue and it’s very frustrating. It has been happening for 2-3 months now. A couple of times a day, I will get the same error with the same behavior as Abinas. I can only open the file if I close Sumatra and reopen it.
I am also on Windows 10, 64bits, personal laptop with an admin account.
What I think happens is that there is a conflict when open files were opened from a different process than the file I am currently trying to open. So, when I have opened a file through Firefox (non-admin), I won’t be able to open a file from Explorer (or vice-versa). The behavior happens both with Q-DIR and Windows Explorer. All apps I use are the 64bit versions. If I close Q-DIR and run the process as admin, I am able to launch the file, but this shouldn’t be required.
I have already uninstalled and reinstalled the latest version of Sumatra 3.3.3 64b installer, with no changes.

Grateful if you could investigate this! Thanks.

I may have identified the problem - the error is replicable when I open a file first through Everything (from Voidtools), then from either Explorer, Q-Dir or Firefox. Opening a file in the other direction (say, Firefox, then Everything) works fine.

I have just uninstalled then reinstalled Everything (making sure not to select “run as admin” in the install process) and the problem seems to be solved for now. That was only a couple of minutes ago, so I will monitor and see if it happens in other instances.

1 Like