EPUB: Can't change text size!


Can’t change the text size when reading an epub file. Is this normal? Can it only change text size if its a PDF? I tried opening a PDF and its a black screen. Just updated it. ??? Does anything work in this program?


Yes, it’s ‘normal’ in the sense that that’s how EbookUI is restricted in terms of functionality. Read this to know more:


About the PDF, are you viewing it with 3.1.2? If so try the latest pre-release build and if that too doesn’t work, open an issue on GitHub with a link to the problem file.


Yes - 3.1.2, just updated yesterday.
Today I thought I might try converting it with Calibre. But before I tried that I decided to see how Calibre displays it. Guess what. Its FLAWLESS. Why bother? The only problem with Calibre’s reader is that I can’t change the font style, though just about everything else works fine. It does scroll side to side which takes some getting used to but is a small price to pay for no errors.

I should say Sumatra displayed the epub with no errors but its just not big enough for my eyes to read for long periods of time on a 24" widescreen monitor. Mobipocket displays it with lots of errors though you have good control over font style, size and everything else. Mobipocket’s weakness is a bizarre implementation of FullScreen that traps you there until you leave FullScreen. When oh when will techies realize that being different is not better? Improving something is better. But a mindless change to be different is just stupid. Common sense: The sad lacking feature of most tech these days from designers not living in the real world around them.


*shrug* Sumatra is what it is till its developer or any other coder (including you if you know how since it’s open source) improves it. Of course you haven’t bothered to link to the problem PDF so the dev can’t fix the issue, if indeed there is one, even if he wants to. Not to mention bugs with the underlying muPDF aren’t his responsibility. Ranting about techies and what not is pointless - just use whatever suits you the best, be it Calibre or Sumatra - no-one else cares. And if you truly want your program of choice to be improved then provide the developer with detailed bug reports or suggestions, then sit back and hope for a quick or at least a favorable response.


I was trying to read an epub file. Sumatra is great for PDF’s. At least it was. Now every PDF I try to open is just a black screen. Any idea what could be causing that?


In that case obviously provide the problematic EPUB instead.

Not sure… Things to try:

  1. Uninstall and reinstall 3.1.2 (ensure %AppData%\SumatraPDF is gone after uninstalling).
  2. Try the latest pre-release build.
  3. Try the portable versions of both 3.1.2 and the latest pre-release build.
  4. Try both 32 and 64-bit releases of the installer/portable versions.