Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Ebook Printing dialog will not open!

I am a new user coming from Calibre b/c one of my ePub files’ pages were being stretched no matter how I tried to preserve the aspect ratio. I mention this b/c I know the file is not protected as it will print to PDF in Calibre, albeit poorly formatted.

I’ve tried View > Print as well as Ctrl+P and the print dialog box won’t even open. Perhaps there’s a command idk as a new user?

Hmm!
Using the Reader Mode printing is not applied as the layout is “variable”
File > Print should not appear
In SumatraPDF for printing you need to switch to the fixed page layout.
Main clue is that then shows the Find option in toolbar.
Later versions have the Debug > Toggle ebook UI option which when on makes the change, However the current file must be Reloaded using R to see the change.

It’s strange, but the File > Print dialog was not “grayed out”; however no action occurred when clicking that menu option.

I was able to find the UI toggle and print to PDF. Unfortunately the PDF seemed as if it it had shrank so that it was not preserving the aspect ration of the cover. Is there any way to remedy this?

Thanks for reminder that 3.2 had the bug of showing “print” in the Reflow Interface (It was not there in 3,1.2 and Its not there in current Pre-releases)

Unfortunately whilst SumatraPDF printing can scale, As Far As I Know, it is always exported as an even ratio (so even if objects are buggy and on screen seem squished, they often print as x = y dpi), so its not normally possible to alter the aspect unless the printer driver has such controls.
SumatraPDF printing will be creating an image only PDF, If I needed to modify one axis scale then I would be considering Batch Image apps such as IrfanView which can work with image PDF.
Before that I would be looking closer at why the problem is there in the first place. is it bad source content or is the ratio badly defined.

when I open up file with .epub format and try to print it via sumatrapdf, it does not even show the print dialog to choose microsoft’s builtin “print to pdf” printer.

solution?

It looks like you may be using release 3.2 which incorrectly showed print icon when in variable ebook UI mode, For printing a Fixed UI /page layout you need to switch to the FixedIU which is done with menu Debug > toggle ebook ui (in english=Alt+D+T) then press R to refresh/reload the document. Then that fixed layout can be printed as images.pdf

MuPDF is an alternative fast means to view but has no natural print function. If you need to produce searchable PDF avoid converting in SumatraPDF as you then need to degrade that output with OCR. There are much better ways to go about converting ebook with fonts to searchable PDF.

So if you still have older MS Edge that could read ePub and print to PDF. but modern Edge chrome version cant read ePub.
EPUB File Reader was a free and simple 1MB lightweight ePUB file viewer that could print each chapter very well but that’s so frustrating as each chapter then needed to be merged with the others.

For converting e-Books to PDF there is one open source leader “Calibre” it can be slow as a reader but for conversions it is possibly the best.

thank you so much for the answer…
if sumatrapdf converts as image’d pdf files, it’s a big no since the file would be huge in size!

actually I can convert via online free converters with ease, but they have daily limit.

I was hoping to convert epub to pdf so it runs faster in sumatrapdf
strangely though, any epub files take much longer to load and are laggy compared to pdf,
Any REASON?

If you are using version 3.2 there have been many improvements since (one reason 3.2 has not been pushed as an update)

So it is worth testing a pre-release (I prefer to use the “daily” updated portable one, but occasionally it may have new hiccups :slightly_smiling_face: )

P.S. should have mentioned if you want to use print NOT as images you could try older portable 3.0 (Previous versions of Sumatra PDF) with print dialog “print as images” setting OFF (unchecked) HOWEVER that did not work well with epub fonts whilst it was ok with PDFs (one reason print as images is now the only method)
Changing font size or font name made no difference ePub in fixed mode printed as searchable PostScript/PDF but when viewed looked like ! thiS [anagram]