Download for x64 installer broken


The link to download the 64-bit installer is broken. The download runs for a little bit but then fails. I’ve tried Firefox, Chrome and Edge to no avail. The downloads for the portable 64-bit version and both 32-bit versions download fine. Any idea what’s up with that?


I assume we’re talking about

You can verify that you have the right executable using

Generated hash should be 593e9b0d96f07783df13f1b311548069961465fb

That being said, I don’t think download is a problem.

The binaries are signed so I think if the download was corrupted, Windows would refuse to run it.

You wrote “The download runs for a little bit but then fails.”.

Fails how? What happens exactly, what is the error message etc.?


What happens is when I click the link, my browser starts to download the file (it shows a completion percentage, ETA, connection speed, all that jazz) but then stops around 10% of the way in and reports that the download failed. The partially downloaded file returns da39a3ee5e6b4b0d3255bfef95601890afd80709 as the hash. And yeah, Windows refuses to run the file what with it not being complete.

When I tried clicking the direct link from your post I got this message in Firefox:

Secure Connection Failed

The connection to was interrupted while the page was loading.

  • The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
  • Please contact the website owners to inform them of this problem.

I never saw that message before. I just tried downloading all the files again. Both 32-bit versions and the portable 64-bit versions download okay. Only the 64-bit installer breaks but now Firefox is showing that error message instead acquiring a partial download. Edge doesn’t show such a error message. Edge still tries and fails to download the 64-bit installer.


It downloads for me so it’s likely some network issue specific to your connection.

You can try a more direct link:


Weird that only the 64 installer would break.

That link worked fine. Thank you for you help.


I’m having a similar issue - the x64 installer will only pull ~500kb before the connection is closed. I’ve tried on Windows and a FreeBSD machine I have and they both fail consistently.

All other downloads on the site work fine and the AWS link to the x64 installer works fine.


Working fine here. Are people still having issues and if so, perhaps it’s a region-specific thing?


I just tried to redownload the file and now it’s coming in no problem. Cox is my ISP and I’m in Cuyahoga county in Ohio, USA.


I retried the x64 installer download again today and its working fine now.