Command line, Debug/Log


#1

I would like to debug and or log all my command line printings. It seams I have an unknown issue and I need to check it deeper. My main usage of SumatraPDF is to print PDF files from server A to a printer on a network. Works fine when I login to server B ( where SumatraPDF is installed ) via remote desktop. When I disconnted from remote desktop, then I have issues that SumatraPDF is not printing PDF files and I need to discover it somehow.


#2

@burademiru

not tried printing between servers however there was a lot of discusion in this thread, If you find a solution there to your problem please reply here, so others may see the answer.


#3

Sumatra does support the following developer command-line option:

-console: Opens a console window alongside SumatraPDF for accessing (MuPDF) debug output

However I’m not sure whether any printing related debug info. is written to the console or not. If it isn’t then you might have to compile and debug your own copy of Sumatra.


#4

Hello GitHubRulesOK and SumatraPeter,

thanks for your reply. I’m currently discovering the issues on the printer and did a test today. At the time when the printer was not printing, I have done a command line script to print on a different network printer and it printed successfully. Tomorrow I’m going to make another test on a similiar printer that did not print.


#5

I have tested the similar printer and the result is the same as before, the similar printer is also not printing but the different printer with success is still successfully printing. I’m still crowling through this issue and will try out different ways and continue searching this issue.


#6

I could not figure out what is causing the trouble at the moment. One thing that worked for 3 days now, is that I reboot the server B ( where SumatraPDF is installed ) every morning automatically and this helps to make it work with printing. Maybe the backup is causing the unknown issue or something else.


#7

Two things spring to mind

  1. can you monitor what resources / services are being used
    a) after reboot
    b} after starting SumatraPDF
    c) after printing
    d) after backup starts
    e} after backup ends
    How do those values compare with a server without problems

  2. does the backup program have features that lock file activity until finished, and is it stepping down / closing cleanly after completion


#8
  1. From Friday until today ( 04.07 ) the server has been rebooted every morning and there was nothing unexpected to monitor. SumatraPDF UI is not started at all and the print command line works. Somehow the print test is not working ( how annoying ) and the backup is fine as well. I did not test SumatraPDF from another server yet but I guess this will be the next try.

  2. Windows error log got no errors or warnings, seams to be everything clean. And the reboot is working without problems.


#9

My skripting test is using a command line print from SumatraPDF and a normal command line with windows print command. SumatraPDF did print the test page the last days and windows print not. Today both did not print but a normal “Windows test print” ( not from my skript ) could print on the printer.


#10

Something strange just happened. My skript print did print while I was logged in on the server where SumatraPDF is installed via remote desktop connection and after disconnecting from remote desktop I did another test printing with my skript and it did not print.


#11

Conclusion:

  • SumatraPDF command line works
  • Printer is working
  • Server got not errors
  • Printing problems remains under an unknown issue and has nothing to do with SumatraPDF or the printers.

The Systemadministrator is clueless, too. I appreciate the replies here and want to say thank you.

Best regards,

Bura