Can't paste pdfs into word


When my default pdf reader is set to SumatraPDF, I can’t paste the contents of a pdf into MS office applications (Word). It does work if my default reader is set to Adobe reader.

All methods I have tried fail: dragging the file from explorer into word, insert -> object -> pdf. Using Adobe reader I can insert the contents of a pdf as a vector image in word. Using SumatraPDF, the file only shows up as an icon.

Clearly Word is using some feature of Adobe reader to insert the file. Is there a way I can accomplish the same if my default reader is SumatraPDF? I don’t want to give that up.


Sumatra doesn’t have any special support for embedding PDF into word.

I don’t know what “using Adobe Reader to insert into word” means but I don’t see how this is related to what application is the default.

You can have Sumatra as default and still open a file in Adobe Reader and use it to insert into Word.


When Adobe reader is my default pdf reader, I can directly insert PDF content into Word (drag and drop, object->insert, etc.). When SumatraPDF is my default pdf reader, I cannot.

Word must somehow be using the default PDF reader to perform a conversion. Ideally, SumatraPDF could make the same function accessible to MS Office.

I understand that this is probably incredibly difficult. In fact, it probably involves specific interface work between Microsoft and Adobe and is therefore extremely unlikely. However, I haven’t been able to find information about this anywhere online, and I thought somebody here might have more insight into this behavior.

By the way–thanks for all your work on this excellent pdf tool.


@jaspast: With the latest version of Word (2016 or the continuously updated version in Office 365), have you tried simply opening your PDFs directly with the program?