Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

[Bug or Just me] Slow Start up if in tabs mode since version 3.3 and 3.4 beta, but not on 3.2

Hello, I’m a SumatraPDF user that use it for fast start up and opening pdf. But since 3.3, I seen slow start up and sometimes it just end up not responding like example

If I change Sumatra PDF into non tabing mode, the start up fro 3.3 and 3.4 beta will be fast. Take not this also happen if I close all past pdf file and start fresh.

Any pointer so I can make it as fast as 3.2? I’m on windows 10 64bit 20H2 , and lag version are 3.4.14210 and 3.3.3 stable. as for 3.2 that still fast on tab mode is 3.2 last commit fc8f35a. All is 64 bit version of sumatrapdf.

Any help really really appreciated. Thanks

Could you quantify “slow” vs. “fast”? Roughly is it seconds, tens of seconds, minutes?

Are the files you’re opening on a network drive like dropbox / google drive / OneDrive etc.?

1 Like

Ah yes. For 3.2 only take 1s for open SumatraPDF GUI for 3.3 and 3.4 takes about 10s-20s and there are CPU spike 3% vs 0-1% on 3.2, every version is opened without any file, just the home of recent file.

My files are local, but I don’t quantify the file, only start up time without file, to open the recent/home gui

for any version, file open normally, only GUI freeze if we want to open the recent view like on screenshoot provided on first post

Hello, does my explanation help sir? Or it doesn’t For now for fast open SumatraPDF I must disable tabs so it will open as fast as on version 3.2 (Because I really fell in love for annotation on new sumatraPDF)

Out of interest is it tabs or your history of tabbed files? so temporarily rename your settings file as a backup so that SumatraPDF needs to build a fresh settings file, then add two tabbed entries that are not on a remote drive but only local hard drive e.g. c:\docs. Close and re-open, . Is it now an expected speed same as without tabs?

It’s just clean non tabs start up.

I already tried to move the exe to other folder to generate new settings.

I’ve no problem with opening the pdf, it’s still fast, the problem is the start up of the apps it self, seems like it wait for the tab to be drawn, and it took sometimes 5s sometimes 10s. If sumatrapdf already opened, tabbing enabled or not it doesn’t matter, only if there’re no sumatrapdf process opened, then it takes about 5s-10s to start the app, even without opening a pdf, start casually start.

If I disabled the tabs, it will open under 1s. click open, click open, no delay at all.

My computer is i7 with 16gb of ram, so it shouldn’t be a problem. Do you have other guess?

My guess is that since I am on a very slow E1 chip and have many apps that crawl but SumatraPDF 64 bit with a few tabs on is not one of those noticeably slower than attempting to open any of my other pdf apps (Xchange can seem like minutes it takes 12 times as long to open one file) and that’s lightweight so opening 12 small files tabbed in SumatraPDF = time for one in other apps, but I dont open large files 12 at a time.

Simple Testing opening 7 files in 3.1.2 takes a bit over 7 seconds fresh or remember on tabs.
The same 7 files opened fresh or remembered in yesterdays pre-rel takes roughly the same time if adding one more certainly 8 normal small files of total pages over 1500 (2 files are 750 page manuals) opening in tabs remembered mode is not much if any slower.

Is there any other source of interference such as are those files included as exploitable by antivirus or in a synchronised folder or monitored for file activity by some indexing app like everything? Are they slowly opening a couple of seconds apart based on size for scanning by another app?

For comparison tested current pre-rel on an even slower atom notebook 10 files over 3500 pages total take variable times the biggest 900 pages and 2500 pages are noticeably slower on loading their tabs but all 10 load within 10 seconds, and even threw in a couple of heic images (1 in a zip) to test its not just pdf however ebubs could be a different factor to test that I did not include.

I forgot to mention, if the tab disabled, the document will opened instantly, under 1s, with tab enabled, well 5s-10s. I think this’s because of tabs module. Is there anyway to debug it. I already tried to clean the folder and use portable sumatrapdf also, only version 3.2 that will opened fast if with tab enabled, and with 3.4 I must disabled tab feature to make it load fast. Even on network location, version 3.4 without tabs load under 1s

From the screenshot it looks like you’re using an alternative windows shell?

If yes, what kind of software is this?

Does anything change if you disable alternative shell?

Also, which version of windows are you using?

Hello, I don’t use any alternative windows shell sadly, It’s plain windows 10 with windows built in shell/Desktop environment, version 20H2, sub build id 19042.1288 X64.

Is there anyway I can help to make this debug simple and help you minimizing guessing sir? because I felt I don’t provide any sufficient information, and seems you and Mr. Ok seems has hard time guessing.

Any suggestion to help the debug really appreciated.

My CPU is i7-2640m, dual core 4 thread, with very low CPU, and slow loading tabs doesn’t spike cpu at all (only 1-2% until the window ready). so seems computation isn’t the problem.

For Application that run on my computer only vim, onedrive, gdrive (new stream version), everything from voidtools, auto hotkey, and built in lenovo sound manager for thinkpad X220.

SumatraPDF already whitelisted from Windows Defender, has read write/bypass anti ransomware, closing ahk/autohotkey and other application doesn’t solve the issue. disabling tabs mode disable the issue.

I use light mode from windows 10 (see Change colors in Windows) so it seems like I use some other shell, but it isn’t, and I change my task bar to small.

“Everything” is an issue depending on mode
see if its disabled helps.

Also you mention AutoHotKey and I see a process monitor in toolbar showing cpu level both those and the one/goggle file syncing will be impacting file handling.

Hello Just tried to turn off/exit both AHK and Everything, still has the issue I mentioned on this thread, slow start if tabs enabled. If the tabs turned off, sumatrapdf will open very fast on version 3.3 stable and 3.4 unstable. This doesn’t affect version 3.2, by any chance is there any notable change on 3.2 for tab handling? Because I can run version 3.2 x64 with everything and AHK nicely/both of them running, no slow startup whatsoever (<=1s, click open directly, even the file is very big, eg 40mb).

Fyi, seems everything and ahk doesn’t cause the issue. And I also try to reproduce the error on the error link that you provided before, I can’t reproduce it with X64 everything. I can open file pdf file normally from everything using sumatra. It’s strange that he encounter it. I’m not using it from installer, but use sumatrapdf portable from the link provided on download page. I don’t know does it make no error when interact with everything or not.

Any Other hunce? I tried this also on quad core i7-2670qm, this thing also happen, slow start if tab enabled. hmm… any more suggestion is really appriciated to test.

I will try to stick with non tabs first for now, as It’s kind like crawling like opening adobe acrobat. I hope the problem can be found soon. Thank you for both of you to offer help.

Running out of ideas except you are keeping file history in your image

SO when you switch tabs off are you still opening many windowed files that were previously on the tabs? thus your settings file is set to keep storing more and more files that are possibly no longer accessible on other remote drives perhaps moved / deleted ?

I suggest close SumatraPDF and rename the settings.txt file as a settings-backup.txt
thus without the history starting SumatraPDF will build a new one
open three local files with tabs on and exit
then see if it is fast starting up with the smaller cleaner settings file.

if the settings file is the issue you could email it to kjk to see if he can determine which entries are causing a difference.

Another question is how many files are in the sumatrapdfcache sub folder ?

I already clean up the cache folder and tried starting the sumatra PDF from other folder as it’s a portable version. I already change the settings and remove it also it still resulting the same condition. It takes about 5s delay to make it ready even with fresh clean folder for portable version, if I turn off the tabs, 1s opened, and ready to do other things. When stuck, the tabs is hidden and seems it takes time to load the tabs module. That’s what I suspect as I already tried it with clean folder and clean setup etc…

Anyway for comparative version 3.2 will load under 1s for start up even with tabs, with clean setup and no recent file whatsoever.