Forum moved here!

Home / Bookmarks links have different behavior in various reader



I am using Sumatra a lot for viewing PDFs and i really appreciate the annotation functionality and simplicity. However, I stumbled on a PDF with a broken table of content (bookmarks). Past a certain point, all links doesn’t work anymore. If that help with diagnostic, I tried opening the same file in Acrobat, I get an error stating “there was a problem reading this document (135)”. I am on a local drive.On Chrome, it displays fine and all links are working, but there is one page that displays empty.

I am looking for a way to fix this PDF and continue Sumatra to read it and work with it.



SumatraPDF uses MuPDF which in turn may have stricter rules about broken files. It can attempt to fix some problems but not those beyond fixing. the best way to see if it helps is to run MuPDF-GL from Artifex however the current version 1.19 MuPDF does not have every fix as they run in a bi-annual release cycle.

When you open a file if it shows an * in the heading it has found an error it is working around so in MuPDF-GL you need to simply press A to save the file (without adding any of the annotations) with a new name.

Any basic problem it can not fix would need a more dedicated manual attempt to repair, with mixed results.


Added link to MuPDF current version 1.19


Thank you for the support. I tried to save as with mupdf-gl and it produced a file that is 100% binary identical. Let me know if you know about some other tools that could work.


For corrupt bookmarks there are none that I know of, other than discard those or edit and or add again, which is often why pirate books often fail with badly imported auto bookmarking from ToCs rather than true Outline.

for one example where version 3.1.2 was marginally better in a few cases see Problem with broken toc · Issue #1367 · sumatrapdfreader/sumatrapdf · GitHub