Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Blank Printing OR low resolution since 9th March 2021

I really cannot fgure this out. In the last few days everythng we print starts off fine then becomes very low reoslution or blank part way throgh the PDF. We have tried from mulitple cimputers and to mulitple printers from multiple PDFs. We have alos tried old and new versions of Sumatra. It happens if we print to a printer or print to a new PDF.
I can print perfectly form Acorbat/Foxit etc but we like Sumatra as the print-as-image works really well.

I am wondering if it;s a windows or anti-virus update as it’s happening at my home as well as at work and they run completely independantly.

[LATER EDIT TL;DR this was a MS windows March 2021 updates issue so skip lower down to see that you need several recent March updates to avoid Blue Screen of Death or poor printing ] If your Windows reports your build as 19042.870 or later you may have the necessary fixes already.

Skim read the trail or to jump down to cause click here

I can see no clear reason for your issue, since you seem to have tested all the bases, past v current output, on/off site, old/new versions, different print methods.

The only way I can test independently to see a potential problem, is if you have a past good source and output from say MS pdf printer, I could compare current output against different versions. but you tried that so first have to ask what versions you used in the past and recently tried.

Another possibility is provide a public link to any source file of similar structure to your own, where you see the problem when using print to pdf. thus I can look for any commonality by doing the same.

The only way a code change can be made is if the cause also affects current DailyBuilds so suggest you ensure you test that portable to verify it affects current code.

Thank you for the prompt reply. For a couple of years we have been using 3.1.2 and it was always worked perfectly until the last few days
I have tried the latest version (all 32/64 and install vs standalone) and it crashes. I have tried the pre-release version and I get the same results as 3.1.2 - it starts off fine then creates either blank pages or very low resolution text. I have tried a number of PDFs and a number of computers and a number of printers both at home and at work - it’s always the same. Foxit, Acrobat and Acrobat Pro don’t have any problems. I will look to see if I can find any PDFs online that have the problem else I might need to work out how to test without publicly linking?

Perhaps a red herring but a similar recent user compliant was missing third page onwards when using -silent (which I avoid since it can cause problems as it knocks out error reporting)

Now the version at home has started working. Will test at work tomorrow as that’s where I need it. Really bizarre how it suddenly started to work. Can’t help feeling it’s something outside Sumatra like windows, av software or some such.

All very odd. 3.1.2 works now at home. Still does not work in the office. However 3.0 works at the office.

3.0 can be image only or non image printing.
but 3.1.2 is only image printing which eats more memory, that can cause problems with high resolution inputs as they multiply by exponents (though not as simple as 2 squared)
Has there been changes in the type of image within the PDF source ?

Yep I had seen that and changed it to PAI in the settings. That’s the whole point we use Sumatra as the PAI option is not available with most other PDF printers when using the command line. The heavy files is an issue but due to the very large number of PDFs we need to print the problems it solves far outweighs the problems it gives.

No change to the types of files. In fact we printed old files we knew had printed perfectly well last week which this week has issues!

Again you seem to have a handle on the potential causes but that seems to point at the tipping point as being outside SumatraPDFs control.
So has somebody including MS updates, changed the driver/settings or added some app that is now using more of the background system resources

I believe it is the operating system as the only common thing between work and home is the user and the OS and I have not done anything differently. There have also been a number of Windows updates in the last week. Don’t believe it is simply an issue with processing as we can print as image from Acrobat perfect well - we can also print very large image files from Photoshop that great Gb+ rasterised files. I believe it is some Windows processes that Sumatra uses to print that have changed but I really don’t know!!
On a completely separate issue, I now realise how much we use Sumatra and how good it is so have donated.

@kjk will appreciate the Kudo$ :heart:

The remaining posibility as you say is the heavy reliance on GDI system for printing and that seems to be potentially a difference that can affect 32bit versus 64bit current daily is only available as 64bit the august pre-release has a 32bit variant. Both may be worth a try as the rendering in memory was significantly changed since 3.1.2 however, the printing method / memory usage has not changed enough to make a difference, but you never know without comparing spool sizes or capturing print to file. In my rough 1 image page virtual printer test 3.0 PAI and newer versions output fairly similar final size, but I did not check how big whilst spooling

We’ve been shipping SumatraPDF 2.3 with our software. About a week and a half we’ve been getting reports that printing PDF’s did not work anymore. Turns out a Windows Update was responsible for that. SumatraPDF still worked, but whenever you printed something it only printed an empty page.

So we have upgraded to the latest version of SumatraPDF (3.2) and tested that locally. Everything worked again. We’ve tested with a limited set of customers and all without any problems.

However, now that we’ve started rolling out to more customers, we’re getting some reports that printing is sometimes in low resolution. Not from every client, but only some. So maybe the low-resolution printing is also related to the same Windows update?

Sounds the same issue as me. 3.0 worked first me. I believe it is a windows update. The problem manifested itself as the first few pages were perfect, then the resolution drops drastically to make the text unreadable followed finally by blank pages.

Interesting. I’ve got one unverified report - I did not properly investigate yet - that basically says the same thing:

“Customer is having low resolution receipts again. Some are sharp, some are empty and others are low resolution.”

I’ll try to manually replace SumatraPDF with version 3.0 for that client and see how that works.

I’ve just had confirmation that SumatraPDF 3.0 solves the issue with low-resolution printing.

One client, that had the original empty pages problem with 2.3 after updating Windows 10, also had the low-resolution problem with SumatraPDF 3.2.

I’ve switched them to SumatraPDF 3.0 and it does not have the low-resolution problem as with SumatraPDF 3.2 and not the empty pages of SumatraPDF 2.3. So it works!

And all version tested use printing as an image (SumatraPDF is called with -print-settings “compat”).

Niels
Thanks for your observations. I would be interested to know if you are using the stock 3.0 which should only be available as 32bit or if it is a different compilation.

Also why 3.0 rather than 3.1.2 (also normally only 32bit) but as you probably know 3.0 has the choice of PIA whereas in 3.1.2 it is the only method. And I was not aware of (or had long forgotten) the no longer documented “compat” directive which is only in 3.0 but not needed in 3.1+ so I guess that answers that.
Is the installer or portable version you use?

Did you see a negative difference in 3.1.2 behaviours, same as the OP (@Mark_Had )?

@kjk the clue? here was the significant GDI+ change in 3.1.0

For what its worth I have not yet seen any visual print problems [later edit I did get one symptomatic BSOD] using an up to date Windows 10 Pro 20H2 OS build 19042.867 which includes
2021-03 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5000802)

However I have NOT yet installed the OPTIONAL
2021-03 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5001567)

Thus wonder which may be the culprit ? see below fix for a fix update description

@Mark_Had @NielsLeenheer

Appears the problem may be known to Microsoft

https://support.microsoft.com/en-us/topic/march-18-2021-kb5001631-os-build-10240-18875-out-of-band-7d61c5da-fd70-4880-8d34-5afbf5fb003f

  • Addresses an issue that fails to print the graphical content in a document after installing the March 9, 2021 update.

So it appears to have started with the update I am using but have no visual problems with !! BUT I did have a BSOD on at least one printing related occasion when running another very intensive deep search, thus had blamed that ?

Windows 10 KB5000802, KB5001567 causing new critical printing issue (windowslatest.com)

Please let us know for the benefit of others if any specific KB update resolves this issue for your clients.

I can confirm that after manually installing the fix printing problems have been solved. SumatraPDF can properly print again both older versions and the latest version.

1 Like

Ok but exactly which fix was it KB5001649
(to clear potential BSOD’s I am very slowly ? is it big? It is Big for a fix to a fix, upping mine to the second problem one KB5001567) so can I then expect a third just as large ?

This gets more and more like “Through the looking Glass” as one machine jumped straight from 5000802 to KB5001649 very quickly (no hint of 5001567) so now reporting as build 19042.870
BUT mine now bumped up to 19042.868 wants to reinstall 2021-01 Update for Windows 10 Version 20H2 for x64-based Systems (KB4589212) then 2021-02 Cumulative Update Preview for .NET Framework 3.5 and 4.8 for Windows 10, version 20H2 for x64 (KB4601554) so did KB5001567 somehow moving one step forward need two steps back i.e. rolled-back something to January ! and now offers 5001649 as optional !! What the Fixing Hell is going on? oh well “In for a penny, in for a pounding”. Lets try that. Why do downloads on a slow machine take forever in hours but seconds on a fast one when the internal network is high speed Gb, Don’t answer that I note this one is only 100Mbps (must put another shovel of coal into this one then, since the 10-25Mb ones are faster)

Ok Microsoft owe me yet another frustrated weekend, but at least all the Win10s are now showing as 19042.870, now what about the Win7’s

And which SumatraPDF variants e.g. is daily pre-release unaffected after fixed since only that one includes latest command line extensions for any paper sizes i.e. “Envelope C#” custom etc.

So there’s quite a a bit of noise about this now on various websites about the problem and I’m confused. Which fix did you do to get it working?