Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Blank icon for PDF files in Windows File Explorer

Thanks for Sumatra PDF reader. I’m using version 3.2 64 bit (installed using the installer, not the portable version) on Windows 10.

A difficulty I’m having is that when Sumatra is my default PDF viewer, in Windows File Explorer the icon for PDF files is blank. For comparison, when Acrobat Reader is my default PDF viewer, PDF files have an icon. Please see pictures below.

This is on a new computer. My previous computer didn’t have this problem.

How can I get the usual icon to appear next to PDF files when Sumatra is my default PDF viewer? I don’t know whether I should be asking this question here or on a Windows forum. I would be grateful for any assistance.

Thanks.

With windows 10 there are problems with the way pdf files are associated (Edge is considered by MS to be the initial default handler) security hash codes were added to try and force changes back to Edge, though that may now be less enforced it is still present.
image

The easiest way to ensure your installed SumatraPDF is default handler and thus shows the yellow icon in place of a red one is to right click a pdf and ignore any old settings (you may see I have 2 older ones!) and go to chose another app
image
Again ignore any old settings, tick the box and select More apps
image
Again !! ignore all old settings and select Look for another app on this PC
image
In the window you need to enter %localappdata%\sumatrapdf or wherever your installation including SumatraPDF.exe is (in my case you dont see it as I installed in program files for multiple users) but a default 3.2 install should have put it in that folder
image

Now selecting that exe should convince Windows that is the default handler for PDF files and change all pdf icons to match. It is long winded and a pain to have to repeat for other files like CBZ or ePub if windows did not associate those too, but its the surest way I know to kick windows into submission that SumatraPDF is king.

Thanks for that detailed explanation @GitHubRulesOK. Unfortunately it didn’t work. I followed your instructions - I chose “Look for another app on this PC” and chose the file SumatraPDF.exe (which opened the file in Sumatra), but the icon for PDF files is still blank.

OK, most odd, that method has in the past always worked to my knowledge. at a console what does windows respond for VER for example this 20H2 shows up as Microsoft Windows [Version 10.0.19042.1052] I will try to install 3.2x64 as single user to see if I can get similar but wonder if an acrobat association is still in effect.

Thanks for your reply. ver gives Microsoft Windows [Version 10.0.19042.1055].

I don’t know if it’s relevant, but it’s a work computer. As far as I can see, the only files where the icon is unexpectedly blank are PDF files when Sumatra is the default PDF viewer (some files like .aux files also have blank icon, but I don’t find that unexpected).

Your version is not too far ahead of me, but you never know. If its “works” computer you may have policy restrictions active but then again I still suspect interference from acrobat which would have had to steal pdf control away from edge.

Hmm I wonder if you set Edge back as handler (perhaps restart PC after) will the icons turn to red (or blue) then if so try again to make them yellow?

Thanks for your reply again. I would think that if there was a restriction, it would stop me from changing the default viewer to Sumatra (which I can do), rather than just block the icon.

If I change the default PDF viewer to Edge, the icons change back to red. Changing the default PDF viewer to Sumatra again changes the icons back to plain white. I don’t know if the default viewer was originally Edge or Acrobat Reader.

I know its no help to be told “works for me” but installing 3.2 to single user location and following the instructions above, After a long delay whilst all red icons changed to yellow throughout the system I see the icon as expected on a pdf and also note the one top right, confirming what app will open the file.
image

Thanks for trying to help me fix this problem @GitHubRulesOK. Worst-case scenario is that I have plain white icons for PDF files, which is only a minor inconvenience.

I dont like unfinished problems and recollect there was an Adobe official post Acrobat uninstall “cleaner” unsure if its still available/applicable but avoid any shysters that claim their non Adobe one is the answer.

1 Like

One last thing that can force icon reset is pick a pdf and go to properties to change selected app On this occasion I pick the one thats showing an icon top of the list.
note also since I tried it before the default Icon has been changed by windows to another one from the exe. Which then makes me raise the question are you sure the installed one has not been corrupted somehow. Perhaps try the latest Daily since 3.3 is imminent.

Thanks for the suggestion. I tried changing the program in Properties but it didn’t work. The icon changed but it was still plain white when Sumatra was selected.

I also tried installing Sumatra 3.1.2 64 bit instead and the PDF icon was still plain white when Sumatra was the default PDF viewer.

I checked my bad associations with nirsoft FileTypesManger and certainly need to reset them due to many prior tested applications Note the default was still red Edge even though I see yellow in explorer also Win2PDF and FlexiPDF are fighting for control so I am changing as follows. but I CANNOT change the User Choice as shown it will give error 5 if I try to change it from EDGE !

1 Like

Have you ticked the option for Always use this app to open .pdf files

Yes, ticked that option.

Sorry it didnt work for you. If you put the tick normally everyfile with that extension should use the icon of the app in windows.

Thanks. I agree that it normally works.

1 Like

An update: PDF files in File Explorer are now correctly showing the yellow and black and white icon. I don’t know what caused the problem to be fixed. My Windows version hasn’t changed.

Thanks for the help.

2 Likes