Forum moved here!

Home / Auto expansion of outline / bookmarks in v3.2


Hi everyone,

I’m just wondering is there any way to turn off automatic expanding of bookmark folders when scrolling? In v3.1.2 it was off by default, so I’m thinking there must be a way to turn it off in this version also.

[Image missing due to server hiccup see description below]

As you can see here, I positioned myself on page 290, and as soon as I scroll to the next page, it immediately expands the bookmark folder.

I usually work with huge electric plans, 1000+ pages, so this would very quickly make the bookmark bar unreadable. Then I have to collapse it all, and then expand only the ones that I really want expanded.



Agreed that in the past when referencing file opening

kjk commented on 27 Jan 2015
Also, we do not automatically expand the nodes.

However, there have been lots of changes made under the hood to handle “Table of Contents” / Bookmarks (with still more potentially on the way)

As a consequence “Bookmarks” code is now significantly different with a few visible surface enhancements such as extra controls and in this case Navigational back tracking of current location in the ToC.

If you wish the behaviour regressed to “Not auto expand” like 3.1.2
Possibly with a user option AutoExpand = true / false then its best to comment the issue at

The easy solution is to rapidly switch the navigation view off (X on the right of bookmarks pane) then use any other means of navigation such as scroll / keyboard then if you wish to again see bookmarks in that state use right click context menu or F12


I agree this is a problem. My document has a Chapter and when I go anywhere within the chapter the bookmark opens up to a huge list. It is cumbersome to scroll back up to where I can collapse it because the bookmark list is so long. It would be better to let the user do the expanding, as desired. I already posted my comment in the link you provided and I thank GitHubRulesOK for the prompt responses!


You dont need to scroll back it is a “tree control”
Just like in explorer or other apps hit left arrow the required number of times for the branch
or fastest right click bookmarks then “Collapse All”

I think there would be less problem with auto expand if it allowed a setting to also auto close non current branches


Left arrow works and makes it OK. For some reason I missed that in the keyboard controls, some of which seemed to have changed. I like that where you are in the expanded bookmarks now gets grayed according to where you are. Good improvement.


Maybe there is already an option for this and i simply haven’t found it. But i would love for an option to lock the expansion of bookmarks. I often need only certain bookmarks but because the program marks the bookmark corresponding to the page you are on, it automatically expands all the bookmarks you are scrolling through which is really annoying when you are dealing with large documents.

Sumatra is still by far the best pdf reader available and i love your work. You guys rock.
Regards Max


We create PDFs with LOTS of bookmarks, often nested many levels deep. As I was reading your post, I thought, “Funny, ours doesn’t do that!” Then I remembered that we still use version 3.1.2.

When 3.2 was released, we evaluated it, and while it is a great piece of software (and I certainly don’t want to disparage the devs), there were enough subtle differences that we weren’t fond of that led us to stick with 3.1.2. Most of these changes would probably never affect the average user, though.

I tested one of our documents with 3.2 and it exhibited the behavior you described. 3.1.2 did not.

You can still get v 3.1.2 from the downloads page if you want to give it a try.

Edit - Ok, so I have egg on my face. I did not read the entire heading nor anything other than the last post before responding. Seems it’s well known that 3.2 behaves differently than 3.1.2. Oops.


On certain PDF files after a while bookmarks start expanding by themselves as I view the document. For example, this file:

It’s okay at first but after I’ve had it open for a few days and navigated around a bit some sections keep expanding themselves even when I don’t view them. Because it’s a massive PDF I keep most of it collapsed most of the time.

The sections seem to open when I’m not looking, e.g. when I have the window minimized or when the computer is sleeping. It happens if I switch away to another full screen window and then back again too.

Sumatra PDF x64 3.2
Windows 8.1 x64


Never noticed that, whist rolling short periods through an open then closed file, only the gripe that they expand and don’t auto collapse. But then from bitter experience I tend to collapse manually.

What is most likely, is you have the “bonus” windows feature of scrolling in un-focused windows set to ON, thus a mouse movement outside SumatraPDF will instruct it to slide a page or two in the background.


Once it starts the only way to stop it is to close the PDF and re-open it, after which it is fine for a while again.


In next release (3.3) this will revert to how it worked in 3.1.2 i.e. the bookmarks tree will no longer auto-expand to match current page.
It’s already available in daily builds