Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Printer dialog will not open!

I am a new user coming from Calibre b/c one of my ePub files’ pages were being stretched no matter how I tried to preserve the aspect ratio. I mention this b/c I know the file is not protected as it will print to PDF in Calibre, albeit poorly formatted.

I’ve tried View > Print as well as Ctrl+P and the print dialog box won’t even open. Perhaps there’s a command idk as a new user?

Hmm!
Using the Reader Mode printing is not applied as the layout is “variable”
File > Print should not appear
In SumatraPDF for printing you need to switch to the fixed page layout.
Main clue is that then shows the Find option in toolbar.
Later versions have the Debug > Toggle ebook UI option which when on makes the change, However the current file must be Reloaded using R to see the change.

It’s strange, but the File > Print dialog was not “grayed out”; however no action occurred when clicking that menu option.

I was able to find the UI toggle and print to PDF. Unfortunately the PDF seemed as if it it had shrank so that it was not preserving the aspect ration of the cover. Is there any way to remedy this?

Thanks for reminder that 3.2 had the bug of showing “print” in the Reflow Interface (It was not there in 3,1.2 and Its not there in current Pre-releases)

Unfortunately whilst SumatraPDF printing can scale, As Far As I Know, it is always exported as an even ratio (so even if objects are buggy and on screen seem squished, they often print as x = y dpi), so its not normally possible to alter the aspect unless the printer driver has such controls.
SumatraPDF printing will be creating an image only PDF, If I needed to modify one axis scale then I would be considering Batch Image apps such as IrfanView which can work with image PDF.
Before that I would be looking closer at why the problem is there in the first place. is it bad source content or is the ratio badly defined.