Make SumatraPDF default application for PDF Files? / Don't ask me Again


#1

We have set Sumatra PDF as default application over the xml file.
(https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/dism-default-application-association-servicing-command-line-options)

Is it possible to disable the question at the first start (Make Sumatra PDF default application for PDF Files? Don’t ask me again).


#2

This question usually arises with windows 10 non-admin users, but if your using DISM I have to presume you are an admin and have enabled users OS rights etc, In which case there are a few suggestions.

There are 3 methods listed here https://www.sumatrapdfreader.org/docs/Setting-Sumatra-as-default-PDF-reader.html
I had no problems on Windows prior to 10 as an admin user in selecting make as default in the SumatraPDF menu > settings > options, UNLESS I FORGOT to check Don’t ask me again

In Windows 10 that request seems to be OVERRIDDEN as EDGE protection instantly redirects it back ! which I suspect is what your are having problems with.

So you would need to try the second method, however that does not always cut it so you could jump straight to the third
The known way to force edge not to reset pdf handling back to itself (apart from uninstalling 10, which was my first choice on 2 out of 4 pcs) as described at the end of the linked guide above is you need to go to Windows Settings > Default app settings > Choose default applications by file type (NOT Set defaults by app) and change it as shown here


#3

I had the same problem.
My solution:
don’t change directly from Edge -> Sumatra.

  • install Adobe Reader.
  • set Adobe Reader as default app
  • set afterwards Sumatra as default app
    This worked for me.

Extra
I installed the add on Open in Pdf

So i’m not dependent of the settings of Windows in the future (as far as my browser is concerned).


#4

With my new installation of windows 10 pro (v 1803) I have the same problem. Your workaround by first enabling Adobe did not work in my case. Also with other filetypes (like cbr) it is not possible for me to set Sumatra as default reader for those types.


#5

@witdem
DO NOT USE third party add-ons to work around this issue since we will NOT be able to support those problems. most of the issues with various windows updates are exactly that i.e ISSUES with the way windows has changed.
IF you wish to support multiple types of file use the install as administrator ENSURE you use OPTIONS if you want to include pdf preview and set as default handler. Windows may ignore SumatraPDFs request to be default .pdf handler and keep resetting .pdf handler to Edge. SO after install follow these SUPORTED instructions https://www.sumatrapdfreader.org/docs/Setting-Sumatra-as-default-PDF-reader.html
there is more on how it keeps changing in this bug report https://github.com/sumatrapdfreader/sumatrapdf/issues/615 and previous https://github.com/sumatrapdfreader/sumatrapdf/issues/438


#6

Finally I was able to make Sumatrapdf default pdf reader, but when I tried to do the same for cbr files it did not work.


#7

It should be fairly simple to reset any type such as CBR in a similar fashion
That is using settings > goto choose default applications by file type scroll down to .cbr and if the box is grey with a cross choose a default and if SumatraPDF is listed select it.

IF not listed (ONLY look for app in the store) then you need to go LONGWAYS round
Find a .cbr file, Right click and from the choices select “open with”
that may show SumatraPDF and a tick box for always use this app to open.cbr files,
Make sure box is ticked
IGNORE the icons and click on the MORE apps
go to the bottom and select
LOOK for more apps find SumatraPDF.exe in either your program files or program files (86)
Select SumatraPDF.EXE, that should fix it, If not you would need to do the same but as the administrator

What MAY happen is when you select open by type you see two (or more) SumatraPDF icons and when you try those it does not seem to work in that case it is best to re START as administrator find a file and reinforce the correct sequence following the LONGWAYs above until you click on SumatraPDF.EXE as the new default opener