Keyboard shortcut changed for using highlight feature on the 11040 pre-release version


#1

The feature of highlight a selected text isn’t working with me in the last version of the pre-release version (11040).

The key ‘h’ is associated with another function (change to previous page), and the others hotkeys to highlight in another colors aren’t working too.

If someone can help me, I’ll be so thankfull.


#2

That’s the current settings I’m using:

For documentation, see https://www.sumatrapdfreader.org/settings3.2.html

MainWindowBackground = #80fff200
EscToExit = false
ReuseInstance = false
UseSysColors = false
RestoreSession = true

FixedPageUI [
TextColor = #000000
BackgroundColor = #ffffff
SelectionColor = #f5fc0c
WindowMargin = 2 4 2 4
PageSpacing = 4 4
]
EbookUI [
FontName = Georgia
FontSize = 12.5
TextColor = #5f4b32
BackgroundColor = #fbf0d9
UseFixedPageUI = false
]
ComicBookUI [
WindowMargin = 0 0 0 0
PageSpacing = 4 4
CbxMangaMode = false
]
ChmUI [
UseFixedPageUI = false
]
ExternalViewers [
]
PrereleaseSettings [
TabWidth = 300
]
ShowMenubar = true
ReloadModifiedDocuments = true
FullPathInTitle = true
ZoomLevels = 8.33 12.5 18 25 33.33 50 66.67 75 100 125 150 200 300 400 600 800 1000 1200 1600 2000 2400 3200 4800 6400
ZoomIncrement = 0

PrinterDefaults [
PrintScale = shrink
]
ForwardSearch [
HighlightOffset = 0
HighlightWidth = 15
HighlightColor = #6581ff
HighlightPermanent = false
]
AnnotationDefaults [
HighlightColor = #ffff60
SaveIntoDocument = false
]
CustomScreenDPI = 0

RememberStatePerDocument = true
UiLanguage = en
ShowToolbar = true
ShowFavorites = false
AssociateSilently = false
CheckForUpdates = true
RememberOpenedFiles = true
EnableTeXEnhancements = false
DefaultDisplayMode = automatic
DefaultZoom = fit page
WindowState = 2
WindowPos = 386 0 593 768
ShowToc = true
SidebarDx = 0
TocDy = 0
ShowStartPage = true
UseTabs = true


#3

I will repeat comments from previous post here as it seems that heading is not directly related to this issue

You will need the pre-release version for highlight, it is not there in “normal” version since it is classed as experimental I suggest you use a “portable” version for testing https://www.sumatrapdfreader.org/prerelease.html 4

Beware there are two modes in advance settings (save into PDF true or false) I suggest you use false as it will not affect your original, however it does mean you need to keep the document.smx file with the pdf
For more info on which key to use for [A]nnotation and how to change its shape or appearance see MyNotes (unofficial) at https://github.com/GitHubRulesOK/MyNotes/blob/master/AppNotes/SumatraPDF/Annotation%20in%20SumatraPDF.pdf


#4

Thanks for the answer.

The github link you’ve shared isn’t working.

I saw all posts about it but what I found is that selecting the text and pressing ‘h’ should highlight the text. However it isn’t working, the ‘h’ key is turning the page out.

[EDIT]

Everything is working well now. The correct link with the necessary information about it is https://github.com/GitHubRulesOK/MyNotes/blob/master/AppNotes/SumatraPDF/Annotation%20in%20SumatraPDF.pdf

[EDIT 2]

The modifications were pretty good, congratolations for the responsible(s)! I’m just missing the shortcuts those were working on the last versions. I liked so much the changes, it’s pretty neater than later versions.


#5

Sorry link was changed due to expanding MyNotes overnight from Pre-Release to All versions of SumatraPDF and thus changing title. :blush: I will edit my link above

The change from [H] to [A] will catch many users out but it always was a “secondary” feature thus subject to change.

You said

That suggests you were using nod5 's Helper AHK which needs changing too, a partial solution is linked to as mentioned in MyNotes