Sumatra PDF is a PDF, ePub, MOBI, CHM, XPS, DjVu, CBZ, CBR reader for Windows

Can not install / update 3.2 (gives an error message)

Backup to a separate location any customisation,
e.g. as a minimum save a copy of your settings advanced options file (SumatraPDF-settings.txt).

Before I tell you to uninstall I need to know where your files came from as I never saw SumatraPDF complain of side-by-side, that sounds like one or other may not be from this master source?
https://www.sumatrapdfreader.org/download-free-pdf-viewer.html

Thank you for your answer
I’ve download it from this site ( https://www.sumatrapdfreader.org/download-free-pdf-viewer.html ) on March 26th.

Even more oddly, I’ve download it again, and the newly downloaded installation works fine

They have the same size (9.161 KB) but they are different (I’ve used a file compare program and it has said to me “Binary files: file1 and file 2 are different”

Maybe the first went bed while I was downloading it? (But such a thin I’ve never happened to me).

Thanks for the feedback
Sometimes a glitch on the line, can cause a small mutation, but that message whilst valid for some broken applications certainly is not normal for Official SumatraPDF.

In the past there have been requests for MD5 or SHA1 testing which can give users some sense of security. However, my opinion is that no hash is better than a compromised one. Thus, I personally consider the best test is one based on herd immunity and often submit suspect files for analysis. One such good utility is https://www.nirsoft.net/utils/hash_my_files.html which allows you to run your SHA-256 result through VirusTotal (however for recent files that have low exposure, results need to be treated with caution).

The downside is occasionally a false positive can be caused by bad analysis

Hi.
I tried to update v3.1.2 to v3.2 (x64) but the installer crashes with an error (incorrect side by side configuration). Windows event logs do not give enough info to spot the problem. I retried v3.1.2 installer and also the v3.3.12538 pre-release instalers (both x64) and they worked Ok.

Also, installer for v3.1.2 x32 worked as well.

Regards.

@Helix751

Second time of a similar report look at the md5 hash as shown above starts 632416f or check the download direct on virus total and if your file is not Signature Date 2020-03-15 00:42:## then it possibly did not complete well

I just downloaded twice to check both x64 installer links are the same as the original installer and virustotal reports sha 256 as
36d95dadf36ceae35f49ba0dff47ff628e3433b1150fb5a845f646be67f90198

This problem seems to crop up for short periods see Dec 2017 Download for x64 installer broken
Unsure it it could be periods of high demand or perhaps a bunch of over zealous antivirus checkers b0rking the downloads

This happens to me every single time I try to download the latest 64-bit installable .exe

@James_Oborn
“Major operating systems will show end users an error message if the software they are trying to install is not signed”

The latest pre-release versions are currently unsigned (in part due to cash flow)

This thread is about 3.2 which was signed but fails to download correctly

Please clarify your use of the word “latest” is it Daily / Pre-Release (unsigned which will install with an error message) OR Full release signed
image

Please include some screenshot or wording to identify which of the many ways Windows creates its errors.
best test is to confirm that the date of signing is as shown above

There is a separate thread about downloads after 3.2 e.g. 3.2+

Hi!
Can t install to my pc (win10-64)
Please find 2 images with errors (exe and zip files)
Thanks in advance

it s the second error message when I try zip

Those type of messages usually indicate a failed (partial) download.
seems to cropup in some regions sometimes !

check the downloads against virus total the first SumatraPDF-prerel-13112-64-install.exe if downloaded without failure should be
fedc90a8c0a2089088f815e62507a56730ef08c1eb9a316c0c7d24342afd20da

it is unsigned so may generate some warnings but will run and should show this screen (beware you may wish to alter options,depending on intended users, if more than one user, then set set install folder to Program Files) see the comments above

image

the 3.2 zip should be
19a210f0fb0bebd9338ab4148a5c710d3e8ea8e57576c1052ecc351972ffa93c
and it should unpack without any problems

I m very sorry
I m not guru
Just “little” end user
I did the scanning
Pls find the image
What am I to do?

Sorry I should have been clearer
the download whilst not detected as a problem is not the correct value for a full download it should read for SumatraPDF-prerel-13112-64-install.exe
as
fedc90a8c0a2089088f815e62507a56730ef08c1eb9a316c0c7d24342afd20da
details
History
Creation Time 2020-08-16 09:28:16
First Seen In The Wild 2019-08-28 20:24:55
First Submission 2020-08-16 10:14:02
Last Submission 2020-08-18 08:07:16
Last Analysis 2020-10-14 18:41:46

the clue yours is not correct is it says you are the first to ask for that file to be tested 1 minute before thus never seen previously (because it is broken)

Thank you for your replay
So… What should I do?
How and where from I can download the right file?
It was my second try BTW

Try the alternative link for that file as lower on page https://www.sumatrapdfreader.org/prerelease.html
you should be able to right click download here
https://kjkpub.s3.amazonaws.com/software/sumatrapdf/prerel/SumatraPDF-prerel-13112-64-install.exe
then check the download gives correct value
fedc90a8c0a2089088f815e62507a56730ef08c1eb9a316c0c7d24342afd20da

thank you very much!
I ve installed!
But… to tell the truth I m disappointed
On Win7 the greatest feature (and the only cause) I ve used the Sumatra was locking scrolling down bar to the next page so the only way to go next page was the arrow.
Here on the new version it s not locked - see UPDATE!
Anyway - thank you very much for your quick answer and for my previous user experience

UPDATE
I m very sorry
I do not know how but now the scrolling to the next page is LOCKED!
Exactly what I need!
Thank you very much!

Locking to page by page is the new “square” icon = “Fit a single page”

no, I did something else
it s not enough

default zoom = fit width (in “options”)

There has been some change to fit width so possible its different to before
using space bar should allow to shift down on same page then move to top of next

Regarding the space - thanks for the tip!
I didn t know