Advanced Settings option not visible?

Hi.
Under Settings, I only have one option, and it’s for selecting the UI language.
In the doc, about customization, it says we can open Advanced Settings under Settings.
I currently use pre-release 3.2.11951, 64-bit, installed version.

Thanks!
François

I think I have seen similar in the past on one occasion
I think it was due to a fulty file / location but am not certain

Can you try one of the portable ones from https://www.sumatrapdfreader.org/dailybuilds.html put it in a folder such as c:\simple\
that will firstly avoid any problems such as “ç” in your username installation
secondly it should provide a comparison and build a fresh SumatraPDF-settings.txt file in that folder which if all is well you can delete the installed SumatraPDF-settings.txt file and see if it rebuilds correctly

Thanks, I’ll try that and let you know.
My user name is just « fb » anyway.

Later,
François

There are 2 ways in which this can happen, both of which tell Sumatra to restrict disk access and therefore remove features that require such disk access.

Option 1: running Sumatra with -restrict flag

Option 2: using sumatrapdfrestrict.ini file and restricting disk access (https://www.sumatrapdfreader.org/docs/Configure-Sumatra-for-restricted-use.html)

2 Likes

Oh, thanks, I have created a sumatrapdfrestrict.ini file indeed to test a few things.
Is this file used even if the -restrict flag is not used on the command-line?
I thought it was working that way. (ini file ignored if -restrict is not used)

They are independent of each other.

-restrict restricts everything. It’s simple to use.

sumatrapdfrestrict.ini gives you more control over what to restrict but requires more work to set up.

Ok, thanks.
That was the culprit!
I’ll download the portable version to experiment with advanced settings.
I’d like to be able to use Sumatra in some kind of kiosk mode, but not full screen, with fixed size and position on the screen.

All the best,
François